Ignore:
Timestamp:
01/16/09 04:25:03 (5 years ago)
Author:
alanbach-guest
Message:
  • Merged updates from Ubuntu 0.10-1ubuntu3
    • Do not build with Pulse-Audio
Location:
pkg/boss/main/libcanberra/trunk/debian
Files:
7 added
1 deleted
8 edited

Legend:

Unmodified
Added
Removed
  • pkg/boss/main/libcanberra/trunk/debian/README.Debian

    r4370 r4908  
    22---------------------- 
    33 
    4 libcanberra can use different backends: null, ALSA or PulseAudio. 
     4libcanberra can use different backends: null, ALSA, PulseAudio, OSS, 
     5GStreamer. 
     6 
    57Since the PulseAudio backend requires PulseAudio >= 0.9.11, this 
    68package uses ALSA for testing purposes. It is planned to use 
     
    1012configurable backend installation. 
    1113 
    12 The backend are loaded with the DSO builtin, in this order "pulse" 
    13 then "alsa". 
     14The GTK+ module is loaded when the GTK_MODULES environment variable 
     15contains the string "canberra-gtk-module". Lennart proposed to enable 
     16this by default when the package is installed. I have to figure out 
     17how to do it correctly in Debian. 
    1418 
    15 The GTK+ module is loaded when the GTK_MODULES environment variable 
    16 contains the string "canberra-gtk-module". 
     19This package target "experimental": libcanberra-gtk requires GTK+ 
     202.13.4 in order to take the XSETTINGS configuration. However, GTK+ 
     212.13 is not available in Debian. But the package still compile with 
     22older version. A patch is included to avoid spurious debug messages. 
    1723 
    18  -- Marc-Andre Lureau <marc-andre.lureau@nokia.com>, Thu, 12 Jun 2008 12:57:16 +0300 
     24 -- Marc-Andre Lureau <marcandre.lureau@gmail.com>, Thu, 28 Aug 2008 19:55:54 +0300 
  • pkg/boss/main/libcanberra/trunk/debian/changelog

    r4525 r4908  
    1 libcanberra (0.6-parsix1) unstable; urgency=low 
     1libcanberra (0.10-parsix1) unstable; urgency=low 
    22 
    3   * Merged updates from Ubuntu 0.6-0ubuntu3 
     3  * Merged updates from Ubuntu 0.10-1ubuntu3 
     4  * Do not build with Pulse-Audio 
    45 
    5  -- Alan Baghumian <alan@technotux.org>  Tue, 18 Nov 2008 10:19:08 -0800 
     6 -- Alan Baghumian <alan@technotux.org>  Thu, 15 Jan 2009 17:38:03 -0800 
     7 
     8libcanberra (0.10-1ubuntu3) jaunty; urgency=low 
     9 
     10  * Let libcanberra-gtk0(-dbg) conflicts/replaces libcanberra-gnome(-dbg) 
     11    (<< 0.10-1) to allow a clean upgrade from Intrepid (LP: #302251). 
     12 
     13 -- Luca Falavigna <dktrkranz@ubuntu.com>  Fri, 28 Nov 2008 20:02:28 +0100 
     14 
     15libcanberra (0.10-1ubuntu2) jaunty; urgency=low 
     16 
     17  * Ship the libcanberra-pulse.so in the libcanberra0 package. 
     18 
     19 -- Luke Yelavich <themuso@ubuntu.com>  Thu, 27 Nov 2008 04:23:30 +1100 
     20 
     21libcanberra (0.10-1ubuntu1) jaunty; urgency=low 
     22 
     23  * Merge from Debian experimental, Remaining changes: 
     24    - Use the Ubuntu sound theme as the default and fallback theme. 
     25    - Update libltdl build dependency. 
     26  * Build-depend on quilt. 
     27  * Build against pulseaudio. 
     28 
     29 -- Luke Yelavich <themuso@ubuntu.com>  Mon, 24 Nov 2008 12:49:10 +1100 
     30 
     31libcanberra (0.10-1) experimental; urgency=low 
     32 
     33  * New Upstream Version 
     34  * Move "canberra-gtk-play" from libcanberra-gtk-dev in libcanberra-gtk0. 
     35  * Add gnome-session-canberra to play log in/out events. 
     36  * Add 52libcanberra-gtk-module_add-to-gtk-modules to /etc/X11/Xsession.d to load 
     37    the GTK module. 
     38  * 0001-Remove-debug-warning-about-GtkSettings-from-2.13.4.patch, 
     39    debian/control, 
     40    debian/README: 
     41    + do not depends on GTK 2.13.4 yet 
     42    + remove debug message about that from canberra-gtk-module 
     43  * Add tdb-dev dependency, for lookup caching. 
     44 
     45 -- Marc-Andre Lureau <marcandre.lureau@gmail.com>  Wed, 10 Sep 2008 22:16:46 +0300 
     46 
     47libcanberra (0.6-0ubuntu3) intrepid; urgency=low 
     48 
     49  * debian/patches/use-ubuntu-theme.patch: Use the ubuntu theme as the 
     50    default and fallback desktop theme, since the freedesktop theme is not 
     51    in the archive. 
     52 
     53 -- Luke Yelavich <themuso@ubuntu.com>  Fri, 10 Oct 2008 14:03:05 +1100 
     54 
     55libcanberra (0.6-0ubuntu2) intrepid; urgency=low 
     56 
     57  * Create new package, libcanberra-gnome, which contains the 
     58    canberra-gtk-play utility, as well as the startup and shutdown autostart 
     59    files needed for GNOME sound events. 
     60  * debian/libcanberra-gtk-dev: Don't ship canberra-gtk-play utility 
     61  * debian/patches/fix-logout-script.patch: Use logout sound rather than 
     62    login sound when logging out. 
     63 
     64 -- Luke Yelavich <themuso@ubuntu.com>  Tue, 23 Sep 2008 16:13:15 +1000 
     65 
     66libcanberra (0.6-0ubuntu1) intrepid; urgency=low 
     67 
     68  * New upstream version 
     69  * debian/control: 
     70    - updated libltdl build-depends 
     71 
     72 -- Sebastien Bacher <seb128@canonical.com>  Tue, 05 Aug 2008 15:26:29 +0200 
    673 
    774libcanberra (0.4-1) unstable; urgency=low 
     
    1784  * Fix symbol files. 
    1885 
    19  -- Alan Baghumian <alan@technotux.org>  Mon, 03 Nov 2008 09:58:41 -0800 
     86 -- Sebastian Dröge <slomo@debian.org>  Sun, 27 Jul 2008 11:51:31 +0200 
    2087 
    2188libcanberra (0.3-1) unstable; urgency=low 
  • pkg/boss/main/libcanberra/trunk/debian/control

    r4525 r4908  
    22Section: libs 
    33Priority: optional 
    4 Maintainer: Marc-Andre Lureau <marcandre.lureau@gmail.com> 
     4Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com> 
     5XSBC-Original-Maintainer: Marc-Andre Lureau <marcandre.lureau@gmail.com> 
    56Uploaders: Sjoerd Simons <sjoerd@debian.org>, Sebastian Dröge <slomo@debian.org> 
    67Build-Depends: debhelper (>= 5), cdbs, m4, libltdl7-dev, dpkg-dev (>= 1.14.13), 
    78    libasound2-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386], 
    89    libvorbis-dev, 
    9     libgtk2.0-dev, 
    10     gtk-doc-tools 
     10    libgtk2.0-dev (>= 2.12), 
     11    tdb-dev (> 1.1), 
     12    gtk-doc-tools, quilt 
    1113Standards-Version: 3.8.0 
    1214Vcs-Git: git://git.debian.org/git/collab-maint/libcanberra.git 
     
    5355Depends: ${shlibs:Depends}, ${misc:Depends} 
    5456Recommends: libcanberra-gtk-module 
     57Conflicts: libcanberra-gnome (<< 0.10-1) 
     58Replaces: libcanberra-gnome (<< 0.10-1) 
    5559Description: Gtk+ helper for playing widget event sounds with libcanberra 
    5660 libcanberra-gtk provides a few functions that simplify libcanberra 
     
    6569Priority: extra 
    6670Depends: ${misc:Depends}, libcanberra-gtk0 (= ${binary:Version}) 
     71Conflicts: libcanberra-gnome-dbg (<< 0.10-1) 
     72Replaces: libcanberra-gnome-dbg (<< 0.10-1) 
    6773Description: libcanberra-gtk libraries detached debugging symbols 
    6874 libcanberra-gtk provides a few functions that simplify libcanberra 
     
    7985Architecture: any 
    8086Depends: ${shlibs:Depends}, 
    81          ${misc:Depends}, 
    82          libcanberra-gtk0 (= ${binary:Version}), 
    83          libcanberra-dev (= ${binary:Version}), 
    84          libgtk2.0-dev (>= 2.10) 
     87         ${misc:Depends}, 
     88         libcanberra-gtk0 (= ${binary:Version}), 
     89         libcanberra-dev (= ${binary:Version}), 
     90         libgtk2.0-dev (>= 2.10) 
    8591Description: a simple abstract interface for playing event sounds 
    8692 libcanberra-gtk provides a few functions that simplify 
     
    100106 A GtkModule which will automatically hook into all kinds of events 
    101107 inside a Gtk+ program and generate sound events from them. 
     108 
     109Package: gnome-session-canberra 
     110Architecture: all 
     111Depends: libcanberra-gtk0 
     112Description: GNOME session log in and log out sound events 
     113 Produce sound events on GNOME session log in and log out. 
     114 . 
     115 This package is using canberra-gtk-play from libcanberra. 
    102116 
    103117Package: libcanberra-gtk-module-dbg 
     
    126140 This package contains the HTML documentation for libcanberra and 
    127141 libcanberra-gtk. 
    128  
    129 Package: libcanberra-gnome 
    130 Architecture: any 
    131 Depends: ${shlibs:Depends}, ${misc:Depends} 
    132 Description: Gtk+ helper for playing widget event sounds with libcanberra 
    133  libcanberra-gtk provides a few functions that simplify libcanberra 
    134  usage from Gtk+. 
    135  . 
    136  Contextual informations are needed to play event sound. This library 
    137  can help to compile directly event sounds property lists based on 
    138  active GtkWidget objects or GdkEvent events. 
    139  .  
    140  This package contains files necessary to get full GNOME sound event 
    141  functionality. 
    142  
    143 Package: libcanberra-gnome-dbg 
    144 Architecture: any 
    145 Priority: extra 
    146 Depends: ${misc:Depends}, libcanberra-gnome (= ${binary:Version}) 
    147 Description: libcanberra-gtk libraries detached debugging symbols 
    148  libcanberra-gtk provides a few functions that simplify libcanberra 
    149  usage from Gtk+. 
    150  . 
    151  Contextual informations are needed to play event sound. This library 
    152  can help to compile directly event sounds property lists based on 
    153  active GtkWidget objects or GdkEvent events. 
    154  . 
    155  This package contains detached debugging symbols for the canberra-gtk-play 
    156  utility. 
  • pkg/boss/main/libcanberra/trunk/debian/libcanberra-gtk-module.install

    r4370 r4908  
    11debian/tmp/usr/lib/gtk-2.0/modules/libcanberra-gtk-module.so 
     2debian/52libcanberra-gtk-module_add-to-gtk-modules /etc/X11/Xsession.d 
  • pkg/boss/main/libcanberra/trunk/debian/libcanberra-gtk0.install

    r4370 r4908  
    11debian/tmp/usr/lib/libcanberra-gtk.so.* 
     2debian/tmp/usr/bin/canberra-gtk-play 
  • pkg/boss/main/libcanberra/trunk/debian/libcanberra0.symbols

    r4370 r4908  
    22* Build-Depends-Package: libcanberra-dev 
    33 CANBERRA_0@CANBERRA_0 0.3 
     4 ca_cache_lookup_sound@Base 0.9 
     5 ca_cache_store_sound@Base 0.9 
    46 ca_context_cache@Base 0.2 
    57 ca_context_cache_full@Base 0.2 
     
    1618 ca_debug@Base 0.4 
    1719 ca_driver_order@Base 0.4 
     20 ca_get_data_dirs@Base 0.9 
     21 ca_get_data_home@Base 0.9 
    1822 ca_lookup_sound@Base 0.2 
     23 ca_lookup_sound_with_callback@Base 0.8 
     24 ca_memdup@Base 0.10 
    1925 ca_mutex_free@Base 0.2 
    2026 ca_mutex_lock@Base 0.2 
  • pkg/boss/main/libcanberra/trunk/debian/rules

    r4525 r4908  
    44include /usr/share/cdbs/1/class/autotools.mk 
    55include /usr/share/cdbs/1/rules/utils.mk 
    6 include /usr/share/cdbs/1/rules/simple-patchsys.mk 
     6include /usr/share/cdbs/1/rules/patchsys-quilt.mk 
    77 
    88common-install-arch:: 
     
    2323        done 
    2424 
    25 DEB_CONFIGURE_EXTRA_FLAGS = --disable-pulse --enable-alsa --enable-gtk --enable-gtk-doc --with-builtin=dso 
     25DEB_CONFIGURE_EXTRA_FLAGS =                     \ 
     26        --disable-pulse                         \ 
     27    --disable-oss               \ 
     28        --enable-alsa                           \ 
     29        --enable-gtk                            \ 
     30        --enable-gtk-doc                        \ 
     31        --enable-tdb                            \ 
     32        --with-builtin=dso 
    2633DEB_DH_MAKESHLIBS_ARGS_ALL = --exclude=usr/lib/gtk-2.0/modules 
    27 DEB_DH_MAKESHLIBS_ARGS_libcanberra0 += -V "libcanberra0 (>= 0.4)" -- -c4 
    28 DEB_DH_MAKESHLIBS_ARGS_libcanberra-gtk0 += -V "libcanberra-gtk0 (>= 0.4)" -- -c4 
     34DEB_DH_MAKESHLIBS_ARGS_libcanberra0 += -V "libcanberra0 (>= 0.10)" -- -c4 
     35DEB_DH_MAKESHLIBS_ARGS_libcanberra-gtk0 += -V "libcanberra-gtk0 (>= 0.10)" -- -c4 
  • pkg/boss/main/libcanberra/trunk/debian/watch

    r4525 r4908  
    66version=3 
    77 
    8 http://0pointer.de/lennart/projects/libcanberra/libcanberra-(.*)\.tar\.gz 
     8http://0pointer.de/public/ libcanberra-(.*)\.tar\.gz 
Note: See TracChangeset for help on using the changeset viewer.