Changeset 4488


Ignore:
Timestamp:
11/12/08 18:15:50 (5 years ago)
Author:
alanbach-guest
Message:
  • Merged updates from Debian 2.24.0-1
Location:
pkg/boss/main/nautilus/trunk/debian
Files:
19 added
3 deleted
8 edited

Legend:

Unmodified
Added
Removed
  • pkg/boss/main/nautilus/trunk/debian/changelog

    r4475 r4488  
    1 nautilus (2.24.1-parsix3) unstable; urgency=low 
    2  
    3   * Added 15_nautilus-gvfs-desktop-key.patch, 16_rtl-fix.patch 
    4     and 17_background-no-delay.patch from Fedora Project 
    5  
    6  -- Alan Baghumian <alan@technotux.org>  Tue, 11 Nov 2008 15:34:28 -0800 
    7  
    8 nautilus (2.24.1-parsix2) unstable; urgency=low 
    9  
    10   * Do not recommend gnome-app-install 
    11  
    12  -- Alan Baghumian <alan@technotux.org>  Mon, 03 Nov 2008 20:51:29 -0800 
    13  
    14 nautilus (2.24.1-parsix1) unstable; urgency=low 
    15  
    16   * Merged updates from Ubuntu 1:2.24.1-0ubuntu1 
    17   * Bump standards version to 3.8.0.1 
    18  
    19  -- Alan Baghumian <alan@technotux.org>  Fri, 31 Oct 2008 23:00:07 -0700 
    20  
    21 nautilus (2.22.5.1-parsix2) unstable; urgency=low 
    22  
    23   * Removed app-install-data from recommends 
    24  
    25  -- Alan Baghumian <alan@memphis-mobile>  Sun, 13 Jul 2008 15:41:30 +0200 
    26  
    27 nautilus (2.22.5.1-parsix1) unstable; urgency=low 
    28  
    29   * Merged updates from Debian 2.22.5.1-1 
    30  
    31  -- Alan Baghumian <alan@technotux.org>  Sun, 13 Jul 2008 14:55:33 +0200 
     1nautilus (2.24.1-parsix4) unstable; urgency=low 
     2 
     3  * Merged updates from Debian 2.24.0-1 
     4 
     5 -- Alan Baghumian <alan@technotux.org>  Wed, 12 Nov 2008 09:09:30 -0800 
     6 
     7nautilus (2.24.0-1) UNRELEASED; urgency=low 
     8 
     9  * New upstream release 
     10  * debian/patches/20_open-with_install.patch: 
     11  - updated to the new version 
     12 
     13 -- Gustavo Noronha Silva <kov@debian.org>  Tue, 23 Sep 2008 00:05:26 -0300 
     14 
     15nautilus (2.22.5.1-2) UNRELEASED; urgency=low 
     16 
     17  * Rename libnautilus-extension1 to libnautilus-extension1a as the ABI  
     18    has changed in an incompatible way. Closes: #493665. 
     19 
     20 -- Josselin Mouette <joss@debian.org>  Sat, 26 Jul 2008 14:19:57 +0200 
    3221 
    3322nautilus (2.22.5.1-1) experimental; urgency=low 
     
    117106 
    118107nautilus (2.22.0-1) experimental; urgency=low 
    119  
    120   [ Loic Minier ] 
    121   * Add a nautilus-extensions-1.0 Provide to nautilus to express the fact that 
    122     nautilus will search for extensions in /usr/lib/nautilus/extensions-1.0; 
    123     this might avoid a long list of Conflicts in nautilus when updating to 
    124     extensions-2.0 (nautilus >= 2.21.2). 
    125  
    126   [ Josselin Mouette ] 
    127   * Demote fam to a Suggests; only g-d-e really needs to recommend it. 
    128108 
    129109  [ Sebastian Dröge ] 
     
    161141 -- Sebastian Dröge <slomo@debian.org>  Sun, 16 Mar 2008 20:30:48 +0100 
    162142 
     143nautilus (2.20.0-7) unstable; urgency=low 
     144 
     145  * 25_disable_sighandler.patch: patch from upstream SVN. Disable the  
     146    horrible signal handler that makes nautilus go wild while filling  
     147    its debug log. Closes: #454764, #494788. 
     148  * Don’t require libselinux on non-linux OSes. Closes: #494645. 
     149 
     150 -- Josselin Mouette <joss@debian.org>  Tue, 16 Sep 2008 08:15:05 +0200 
     151 
     152nautilus (2.20.0-6) unstable; urgency=low 
     153 
     154  * 24_smb_crash.patch: patch from upstream to handle NULL MIME types  
     155    set by the SMB module gracefully, avoiding a lot of crashes. 
     156 
     157 -- Josselin Mouette <joss@debian.org>  Mon, 21 Jul 2008 17:09:01 +0200 
     158 
     159nautilus (2.20.0-5) unstable; urgency=low 
     160 
     161  * 05_places-sidebar_single-click.patch: replaced by upstream version  
     162    of the patch, that does not activate items while right-clicking  
     163    them. Closes: #414960. 
     164  * 06_dont_create_Desktop.patch,  
     165    20_upstream_nautilus-dnd-user-owned.patch: make patches apply with  
     166    -p1. Closes: #484953. 
     167  * Recommend app-install-data and synaptic now that libeel doesn’t  
     168    anymore. 
     169 
     170 -- Josselin Mouette <joss@debian.org>  Fri, 18 Jul 2008 13:27:27 +0200 
     171 
     172nautilus (2.20.0-4) unstable; urgency=low 
     173 
     174  [ Loic Minier ] 
     175  * Add a nautilus-extensions-1.0 Provide to nautilus to express the fact that 
     176    nautilus will search for extensions in /usr/lib/nautilus/extensions-1.0; 
     177    this might avoid a long list of Conflicts in nautilus when updating to 
     178    extensions-2.0 (nautilus >= 2.21.2). 
     179 
     180  [ Josselin Mouette ] 
     181  * Demote fam to a Suggests; only g-d-e really needs to recommend it. 
     182  * 02_trash_location.patch: new patch. When unmounting a volume with a  
     183    non-empty trash, take into account that with the new location, the  
     184    directory to remove is the parent of the one returned by gnome-vfs. 
     185 
     186 -- Josselin Mouette <joss@debian.org>  Wed, 28 May 2008 01:47:28 +0200 
     187 
    163188nautilus (2.20.0-3) unstable; urgency=low 
    164189 
  • pkg/boss/main/nautilus/trunk/debian/control

    r4387 r4488  
    33Priority: optional 
    44Maintainer: Josselin Mouette <joss@debian.org> 
    5 Uploaders: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org> 
     5Uploaders: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>, Sebastian Dröge <slomo@debian.org> 
    66Build-Depends: debhelper (>= 5), 
    77               cdbs (>= 0.4.41), 
     
    1111               libgnomeui-dev (>= 2.16.0-2), 
    1212               libbonobo2-dev (>= 2.15), 
    13                libeel2-dev (>= 2.24.0), 
     13               libeel2-dev (>= 2.21.90), 
    1414               librsvg2-dev (>= 2.16.0-2), 
    1515               libgnome-desktop-dev (>= 2.9.91), 
    1616               libgconf2-dev (>= 2.6.1-2), 
    1717               librsvg2-common (>= 2.16.0-2), 
     18               desktop-base (>= 0.2), 
    1819               libxml-parser-perl, 
    19                gnome-pkg-tools (>= 0.10), 
     20               gnome-pkg-tools (>= 0.13), 
    2021               dpkg-dev (>= 1.13.19), 
    2122               libxt-dev, 
     
    2526               libstartup-notification0-dev (>= 0.8), 
    2627               docbook-utils, 
    27                libselinux1-dev, 
    28                libglib2.0-dev (>= 2.17.5), 
     28               libselinux1-dev | not+linux-gnu, 
     29               libglib2.0-dev (>= 2.15.6), 
    2930               libgnome2-dev (>= 2.14.0), 
    3031               libpango1.0-dev (>= 1.1.2), 
    3132               x11proto-core-dev, 
     33               libtrackerclient-dev (>= 0.0.1), 
     34               libbeagle-dev, 
    3235               libexempi-dev (>= 1.99.5), 
    3336               intltool (>= 0.35.0) 
     
    3538VCS-Browser: http://svn.debian.org/wsvn/pkg-gnome/desktop/unstable/nautilus/ 
    3639VCS-Svn: svn://svn.debian.org/svn/pkg-gnome/desktop/unstable/nautilus/ 
    37 Standards-Version: 3.8.0.1 
     40Standards-Version: 3.8.0 
    3841 
    3942Package: nautilus 
     
    4851         gvfs-backends 
    4952Provides: nautilus-extensions-2.0 
    50 Recommends: eject, 
     53Recommends: desktop-base (>= 0.2), 
     54            eject, 
    5155            nautilus-cd-burner (>= 2.6), 
    5256            librsvg2-common, 
    53             xdg-user-dirs 
     57            xdg-user-dirs, 
     58            synaptic, 
     59            app-install-data 
    5460Suggests: eog, 
    5561          evince | pdf-viewer, 
    5662          totem | mp3-decoder, 
    57           gamin | fam 
     63          tracker, 
     64          fam 
    5865Conflicts: libnautilus2-2, 
    5966           libnautilus2-dev 
     
    8592 debugging symbols needed by gdb. 
    8693  
    87 Package: libnautilus-extension1 
     94Package: libnautilus-extension1a 
    8895Architecture: any 
    8996Section: libs 
    9097Depends: ${misc:Depends}, 
    9198         ${shlibs:Depends} 
    92 Conflicts: libnautilus2-2 
    93 Replaces: libnautilus2-2 
     99Conflicts: libnautilus2-2, libnautilus-extension1 
     100Replaces: libnautilus2-2, libnautilus-extension1 
    94101Description: libraries for nautilus components - runtime version 
    95102 Nautilus is the official file manager and graphical shell for the 
     
    101108Architecture: any 
    102109Section: libdevel 
    103 Depends: libnautilus-extension1 (= ${binary:Version}), 
    104          libglib2.0-dev (>= 2.17.5), 
     110Depends: libnautilus-extension1a (= ${binary:Version}), 
     111         libglib2.0-dev (>= 2.15.6), 
    105112         libgtk2.0-dev (>= 2.10.0), 
    106113         ${shlibs:Depends} 
  • pkg/boss/main/nautilus/trunk/debian/control.in

    r4387 r4488  
    1111               libgnomeui-dev (>= 2.16.0-2), 
    1212               libbonobo2-dev (>= 2.15), 
    13                libeel2-dev (>= 2.24.0), 
     13               libeel2-dev (>= 2.21.90), 
    1414               librsvg2-dev (>= 2.16.0-2), 
    1515               libgnome-desktop-dev (>= 2.9.91), 
    1616               libgconf2-dev (>= 2.6.1-2), 
    1717               librsvg2-common (>= 2.16.0-2), 
     18               desktop-base (>= 0.2), 
    1819               libxml-parser-perl, 
    19                gnome-pkg-tools (>= 0.10), 
     20               gnome-pkg-tools (>= 0.13), 
    2021               dpkg-dev (>= 1.13.19), 
    2122               libxt-dev, 
     
    2526               libstartup-notification0-dev (>= 0.8), 
    2627               docbook-utils, 
    27                libselinux1-dev, 
    28                libglib2.0-dev (>= 2.17.5), 
     28               libselinux1-dev | not+linux-gnu, 
     29               libglib2.0-dev (>= 2.15.6), 
    2930               libgnome2-dev (>= 2.14.0), 
    3031               libpango1.0-dev (>= 1.1.2), 
    3132               x11proto-core-dev, 
     33               libtrackerclient-dev (>= 0.0.1), 
     34               libbeagle-dev, 
    3235               libexempi-dev (>= 1.99.5), 
    3336               intltool (>= 0.35.0) 
     
    3538VCS-Browser: http://svn.debian.org/wsvn/pkg-gnome/desktop/unstable/nautilus/ 
    3639VCS-Svn: svn://svn.debian.org/svn/pkg-gnome/desktop/unstable/nautilus/ 
    37 Standards-Version: 3.8.0.1 
     40Standards-Version: 3.8.0 
    3841 
    3942Package: nautilus 
     
    4851         gvfs-backends 
    4952Provides: nautilus-extensions-2.0 
    50 Recommends: eject, 
     53Recommends: desktop-base (>= 0.2), 
     54            eject, 
    5155            nautilus-cd-burner (>= 2.6), 
    5256            librsvg2-common, 
    53             xdg-user-dirs 
     57            xdg-user-dirs, 
     58            synaptic, 
     59            app-install-data 
    5460Suggests: eog, 
    5561          evince | pdf-viewer, 
    5662          totem | mp3-decoder, 
    57           gamin | fam 
     63          tracker, 
     64          fam 
    5865Conflicts: libnautilus2-2, 
    5966           libnautilus2-dev 
     
    8592 debugging symbols needed by gdb. 
    8693  
    87 Package: libnautilus-extension1 
     94Package: libnautilus-extension1a 
    8895Architecture: any 
    8996Section: libs 
    9097Depends: ${misc:Depends}, 
    9198         ${shlibs:Depends} 
    92 Conflicts: libnautilus2-2 
    93 Replaces: libnautilus2-2 
     99Conflicts: libnautilus2-2, libnautilus-extension1 
     100Replaces: libnautilus2-2, libnautilus-extension1 
    94101Description: libraries for nautilus components - runtime version 
    95102 Nautilus is the official file manager and graphical shell for the 
     
    101108Architecture: any 
    102109Section: libdevel 
    103 Depends: libnautilus-extension1 (= ${binary:Version}), 
    104          libglib2.0-dev (>= 2.17.5), 
     110Depends: libnautilus-extension1a (= ${binary:Version}), 
     111         libglib2.0-dev (>= 2.15.6), 
    105112         libgtk2.0-dev (>= 2.10.0), 
    106113         ${shlibs:Depends} 
  • pkg/boss/main/nautilus/trunk/debian/nautilus.1

    r4333 r4488  
    1717.\" for manpage-specific macros, see man(7) 
    1818.SH NAME 
    19 nautilus \- the GNOME File Manager 
     19Nautilus \- the GNOME File Manager 
    2020.SH SYNOPSIS 
    2121.B nautilus 
  • pkg/boss/main/nautilus/trunk/debian/nautilus.install

    r4333 r4488  
    1 debian/mount-archive.desktop usr/share/applications 
    21debian/tmp/usr/bin 
    32debian/tmp/usr/share/applications 
  • pkg/boss/main/nautilus/trunk/debian/patches/99_ltmain_as-needed.patch

    r4333 r4488  
    1 Index: nautilus-2.23.4/ltmain.sh 
    2 =================================================================== 
    3 --- nautilus-2.23.4.orig/ltmain.sh      2008-02-08 01:54:46.000000000 +0100 
    4 +++ nautilus-2.23.4/ltmain.sh   2008-06-17 10:01:06.000000000 +0200 
    5 @@ -1807,6 +1807,11 @@ 
     1--- a/ltmain.sh 2007-10-09 07:38:25.000000000 +0200 
     2+++ b/ltmain.sh 2007-10-09 07:39:25.000000000 +0200 
     3@@ -1794,6 +1794,11 @@ 
    64        arg=`$echo "X$arg" | $Xsed -e "s/^ //"` 
    75        ;; 
     
    108+       deplibs="$deplibs $arg" 
    119+       continue 
    12 +       ;;       
     10+       ;; 
    1311+ 
    1412       -Wl,*) 
    1513        args=`$echo "X$arg" | $Xsed -e "$sed_quote_subst" -e 's/^-Wl,//'` 
    1614        arg= 
    17 @@ -2150,6 +2155,16 @@ 
     15@@ -2137,6 +2142,15 @@ 
    1816        lib= 
    1917        found=no 
     
    2826+         continue 
    2927+         ;; 
    30 + 
    3128        -mt|-mthreads|-kthread|-Kthread|-pthread|-pthreads|--thread-safe|-threads) 
    3229          if test "$linkmode,$pass" = "prog,link"; then 
  • pkg/boss/main/nautilus/trunk/debian/patches/series

    r4475 r4488  
    1 07_desktop_file_activation.patch 
     1#07_desktop_file_activation.patch 
     2#10_location_titlebar.patch 
    2312_list-view_expand.patch 
     414_sidebar_network-protocol.patch 
    3515_nautilus-gvfs-desktop-key.patch 
    4616_rtl-fix.patch 
    5717_background-no-delay.patch 
     820_open-with_install.patch 
    6999_ltmain_as-needed.patch 
  • pkg/boss/main/nautilus/trunk/debian/rules

    r4338 r4488  
    88include /usr/share/gnome-pkg-tools/1/rules/clean-la.mk 
    99include /usr/share/gnome-pkg-tools/1/rules/gnome-version.mk 
     10include /usr/share/gnome-pkg-tools/1/rules/patch-translations.mk 
    1011-include /usr/share/gnome-pkg-tools/1/rules/gnome-get-source.mk 
    1112 
     
    1516DEB_CONFIGURE_EXTRA_FLAGS += --libexecdir=/usr/lib/nautilus --disable-update-mimedb 
    1617LDFLAGS += -Wl,-z,defs -Wl,-O1 -Wl,--as-needed 
    17 DEB_DH_MAKESHLIBS_ARGS_libnautilus-extension1 += -V 'libnautilus-extension1 (>= 2.22.2)' 
     18DEB_DH_MAKESHLIBS_ARGS_libnautilus-extension1a += -V 'libnautilus-extension1 (>= 2.21.6)' 
    1819 
    1920binary-post-install/nautilus-data:: 
Note: See TracChangeset for help on using the changeset viewer.