Changeset 2316


Ignore:
Timestamp:
10/23/07 19:14:00 (7 years ago)
Author:
alanbach-guest
Message:

A fix to make it possible to build older versions than upstream too

File:
1 edited

Legend:

Unmodified
Added
Removed
  • scripts/autobuild.bash

    r2310 r2316  
    55# 
    66# Created: 2007-10-20 15:10 +330 GMT 
    7 # Updated: 2007-10-23 18:17 +330 GMT 
     7# Updated: 2007-10-23 20:43 +330 GMT 
    88# 
    99# TODO: 
     
    156156UPSTREAM_VERSION=`uscan --report --dehs --check-dirname-level 0 trunk/ | grep upstream-version | awk 'BEGIN{FS=">"}{print $2}' | awk 'BEGIN{FS="<"}{print $1}'` 
    157157UPSTREAM_TARBALL_URL=`uscan --report --dehs --check-dirname-level 0 trunk/ | grep upstream-url | awk 'BEGIN{FS=">"}{print $2}' | awk 'BEGIN{FS="<"}{print $1}'` 
    158 echo "${YELLOW}$UPSTREAM_VERSION${NORMAL}" 
     158 
     159if [ ! -z `echo "$PKG_VERSION" | awk 'BEGIN{FS=":"}{print $2}'` ]; then 
     160   PKG_VERSION=`echo "$PKG_VERSION" | awk 'BEGIN{FS=":"}{print $2}'` 
     161fi 
     162 
     163if [ ! "$UPSTREAM_VERSION" = "$PKG_VERSION" ]; then 
     164   UPSTREAM_VERSION="$PKG_VERSION" 
     165   echo "${YELLOW}Prepared $UPSTREAM_VERSION${NORMAL}" 
     166else 
     167   echo "${YELLOW}$UPSTREAM_VERSION${NORMAL}" 
     168fi 
    159169 
    160170# Log filename 
Note: See TracChangeset for help on using the changeset viewer.