source: pkg/raul/non-free/fglrx-driver/trunk/debian/changelog @ 7535

Revision 7535, 52.6 KB checked in by alanbach-guest, 3 years ago (diff)
  • Refreshed 05_fix_2.6.37.patch
Line 
1fglrx-driver (1:10-9-3.2) unstable; urgency=low
2
3  * Refreshed 05_fix_2.6.37.patch
4
5 -- Alan Baghumian <alan@technotux.org>  Sat, 12 Mar 2011 13:09:08 -0800
6
7fglrx-driver (1:10-9-3.1) unstable; urgency=low
8
9  * Added 2.6.37 compilation patch
10
11 -- Alan Baghumian <alan@technotux.org>  Tue, 08 Mar 2011 19:16:29 -0800
12
13fglrx-driver (1:10-9-3) unstable; urgency=high
14
15  * Avoid attempting to build dkms modules for virtual linux-image packages
16    (closes: #597792).
17  * Use a kernel headers path that's also available to locally built kernels
18    (closes: #597783).
19
20 -- Michael Gilbert <michael.s.gilbert@gmail.com>  Wed, 22 Sep 2010 22:58:52 -0400
21
22fglrx-driver (1:10-9-2) unstable; urgency=high
23
24  * Use arch_compat_alloc_user_space in place of the now unavailable
25    comat_alloc_user_space function in newer kernels (closes: #597478).
26    - Thanks to Ubuntu (Evan Broder) for the inspiration for a more robust fix.
27
28 -- Michael Gilbert <michael.s.gilbert@gmail.com>  Sun, 19 Sep 2010 22:53:35 -0400
29
30fglrx-driver (1:10-9-1) unstable; urgency=low
31
32  * New upstream release.
33    - Most DDX bugs are fixed now. If you still get some screen regressions,
34      please report a new bug.
35      Closes: #587824
36
37 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 16 Sep 2010 18:00:05 +0200
38
39fglrx-driver (1:10-8-1) unstable; urgency=low
40
41  [ Patrick MatthÀi ]
42  * New upstream release.
43    Closes: #594606
44    - Now the textures in supertuxkart are realy rendered correctly.
45      Closes: #586797
46  * Start atieventsd before $x-display-manager.
47    Closes: #593703
48  * Depend on virtual package xorg-video-abi-6.0 and provide xorg-driver-video.
49    Closes: #585433
50
51  [ Michael Gilbert ]
52  * Build modules for all installed kernel packages rather than only for the
53    currently active/running kernel.
54
55 -- Patrick MatthÀi <pmatthaei@debian.org>  Sat, 28 Aug 2010 09:05:52 +0200
56
57fglrx-driver (1:10-7-1) unstable; urgency=low
58
59  [ Michael Gilbert ]
60  * Use fglrx module makefile instead of its make.sh script (this has the
61    added bonus of making dkms autoupdate for all installed kernels; thus
62    making module rebuilds for ABI bumps automatic).
63    Closes: #588447
64  * Fix typo in atiode manpage.
65    Closes: #586808
66
67  [ Patrick MatthÀi ]
68  * New upstream release.
69    - Remove patch 06-build-with-2.6.34.diff, merged by upstream.
70    - This release should fix the texture rendering problem with supertuxkart.
71      Closes: #586797
72    - xserver crashes without a defined BusID should be gone now.
73      Closes: #587708
74  * Remove Bertrand Marc from uploaders. Thanks for your previous work!
75  * Reference to the radeon driver, instead of the deprecated radeonhd one.
76  * Bump Standards-Version to 3.9.1.
77    - Move some conflicts to breaks.
78
79 -- Patrick MatthÀi <pmatthaei@debian.org>  Mon, 26 Jul 2010 21:19:32 +0200
80
81fglrx-driver (1:10-6-1) unstable; urgency=low
82
83  * New upstream release.
84    - Refresh 01-CONFIG_X86_XEN.diff.
85    - Drop patch 05_fix_cmpxchg.diff, merged by upstream.
86  * Add danish translation from Joe Dalton.
87    Closes: #584290
88
89 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 17 Jun 2010 10:55:06 +0200
90
91fglrx-driver (1:10-5-1) unstable; urgency=low
92
93  * New upstream release.
94    - Drop patch 02-add-new-cards.diff, merged by upstream.
95  * s/approriate/appropriate/ in fglrx-modules-dkms long description.
96    Closes: #582662
97
98 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 27 May 2010 12:51:48 +0200
99
100fglrx-driver (1:10-4-2) unstable; urgency=low
101
102  * The fglrx-driver package conflicts against the nvidia-glx package.
103    Closes: #581776
104  * Fix a few typos in the long descriptions.
105    Closes: #581954
106  * Update to the new fglrx 10-4 release. AMD silently updated the original
107    tarball. This patch adds support for new cards.
108  * Speed up package building by adding --ignore options in debian/rules.
109  * Add patch 06-build-with-2.6.34.diff to build against Linux 2.6.34.
110
111 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 20 May 2010 21:48:55 +0200
112
113fglrx-driver (1:10-4-1) unstable; urgency=low
114
115  * New upstream release.
116    - And again the paths have been changed, thanks Ubuntu..
117  * Add spanish translation from Ricardo Fraile.
118    Closes: #579516
119
120 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 29 Apr 2010 19:09:04 +0200
121
122fglrx-driver (1:10-4~prerelease-1) unstable; urgency=low
123
124  [ Michael Gilbert ]
125  * Use a better reference for known supported hardware in the fglrx manpage.
126
127  [ Patrick MatthÀi ]
128  * New upstream pre-release.
129    - Segfaulting of the driver is now fixed.
130      Closes: #576575
131    - The compositing problems with KDE should be fixed now, too.
132      Closes: #571036
133    - Rediff all patches, because of changed paths in the tarball.
134
135 -- Patrick MatthÀi <pmatthaei@debian.org>  Sun, 18 Apr 2010 18:03:49 +0200
136
137fglrx-driver (1:10-3~prerelease-3) unstable; urgency=low
138
139  * Please note: This release is in real the 10-4 pre-release.
140  * Refresh 05_fix_cmpxchg.diff, so that fglrx now realy builds with Linux
141    2.6.33.
142    Closes: #571272
143
144 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 25 Mar 2010 19:27:54 +0100
145
146fglrx-driver (1:10-3~prerelease-2) unstable; urgency=low
147
148  * Add workaround, so that the i386 package, does not depend on a amd64
149    only package.
150    Closes: #574973
151  * Fix supported hardwares of fglrx in the documentations.
152    Closes: #574916
153
154 -- Patrick MatthÀi <pmatthaei@debian.org>  Mon, 22 Mar 2010 18:14:54 +0100
155
156fglrx-driver (1:10-3~prerelease-1) unstable; urgency=low
157
158  [ Michael Gilbert ]
159  * New upstream pre-release.
160    - Upstream 8.721 pre-release tarball copied directly from Ubuntu, thanks!
161    - Now supports xorg 7.5!
162      Closes: #564444
163  * Remove fglrxrc manpage since there is no fglrxrc binary anymore.
164  * Add link to ATI FAQ for supported hardware in fglrx manpage (too hard to
165    keep up to date otherwise).
166  * Use autogen to generate manpage build system.
167    - Remove a lot of files that are automatically generated.
168
169  [ Patrick MatthÀi ]
170  * Blacklist the radeon kernel module while fglrx is installed.
171  * Adjust lintian override.
172
173 -- Patrick MatthÀi <pmatthaei@debian.org>  Sun, 21 Mar 2010 23:20:43 +0100
174
175fglrx-driver (1:10-2-2) unstable; urgency=low
176
177  * Remove diversion of libdri.so.
178    Closes: #571124
179  * Add patch 05_fix_cmpxchg.diff to build with Linux 2.6.33. Much thanks for
180    this patch to Stefan BÃŒhler.
181    Closes: #571272
182
183 -- Patrick MatthÀi <pmatthaei@debian.org>  Sun, 28 Feb 2010 12:55:50 +0100
184
185fglrx-driver (1:10-2-1) unstable; urgency=low
186
187  * New upstream release.
188    - xorg 7.5 support? Haha, no..
189    - Adjust lintian overrides.
190  * Add libatiuki to the fglrx-glx-ia32 package.
191
192 -- Patrick MatthÀi <pmatthaei@debian.org>  Wed, 17 Feb 2010 20:28:54 +0100
193
194fglrx-driver (1:10-1-1) unstable; urgency=low
195
196  * New upstream release.
197    - And yeah, still no xorg 7.5 support.
198    - Drop patch 05-fix_missing_signal_include, merged upstream.
199    - Adjust lintian overrides.
200  * Add Brazilian Portuguese translation from Rafael Henrique da Silva Correia.
201    Closes: #565309
202  * Bump Standards-Version to 3.8.4 (no changes needed).
203  * Add missing dependency on remote_fs in the atieventsd init script.
204  * Do not use asterisks in the NEWS file.
205  * Remove old diversion for libdri.so, which is not provided anymore.
206
207 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 28 Jan 2010 19:32:10 +0100
208
209fglrx-driver (1:9-12-1) unstable; urgency=low
210
211  * New upstream release.
212    - What the fuck? They embedded Qt4? We use our own version:
213      Adding libqt4-dev as build dependency and remove those fucking RPATHs
214      from amdcccle.
215    - Adjust lintian overrides.
216  * Simplify the lintian overrides for the fglrx-modules-dkms package.
217
218 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 17 Dec 2009 19:09:48 +0100
219
220fglrx-driver (1:9-11-2) unstable; urgency=low
221
222  * Applied patch from Daniel Schaal, which only adds the fglrx module for one
223    time to dkms.
224    Closes: #557316
225  * Rediff hunky 01-CONFIG_X86_XEN patch. This fixes a FTBFS.
226
227 -- Patrick MatthÀi <pmatthaei@debian.org>  Mon, 23 Nov 2009 10:13:47 +0100
228
229fglrx-driver (1:9-11-1) unstable; urgency=low
230
231  * New upstream release.
232  * Add new XvBA libraries.
233    Closes: #554470
234  * Convert package to quilt and the 3.0 (quilt) format.
235  * Generate now tar.bz2 compressed tarballs.
236  * Add a script for reportbug to every package, se we get the most significant
237    informations in our reports.
238  * Remove unused lintian overrides.
239
240 -- Patrick MatthÀi <pmatthaei@debian.org>  Wed, 18 Nov 2009 09:48:02 +0100
241
242fglrx-driver (1:9-10-2) unstable; urgency=low
243
244  * Implemented dkms support with our new fglrx-modules-dkms package.
245  * Remove old fglrx-amdcccle and fglrx-kernel-src dummy packages.
246  * Fix VERSION and UPSTREAM_VERSION in debian/rules.
247  * Replace my old email address in the dpatch headers.
248  * Add 05-fix_missing_signal_include.dpatch, which lets fglrx compile against
249    Linux 2.6.32-rc5. Thanks to Stefan BÃŒhler for his patch.
250    Closes: #554401
251
252 -- Patrick MatthÀi <pmatthaei@debian.org>  Wed, 04 Nov 2009 17:53:54 +0100
253
254fglrx-driver (1:9-10-1) unstable; urgency=low
255
256  * New upstream release.
257    - This release adds support for Linux 2.6.31.
258      Closes: #546933
259  * Remove unused lintian overrides.
260
261 -- Patrick MatthÀi <pmatthaei@debian.org>  Fri, 23 Oct 2009 18:34:25 +0200
262
263fglrx-driver (1:9-9-2) unstable; urgency=low
264
265  [ Michael Gilbert ]
266  * New manpages for atiode and atiodcli.
267  * Clean-up of many unnecessary files in debian/man.
268
269  [ Patrick MatthÀi ]
270  * Reintroduce missing debian/man files and realy build the new manpages.
271  * Add new lintian override for spelling-error-in-binary.
272  * Add doc-base section. This also fixes a lintian warning.
273
274 -- Patrick MatthÀi <pmatthaei@debian.org>  Sun, 18 Oct 2009 00:10:07 +0200
275
276fglrx-driver (1:9-9-1) unstable; urgency=low
277
278  * New upstream release.
279    - Adjust source and fglrx-driver lintian overrides.
280
281 -- Patrick MatthÀi <pmatthaei@debian.org>  Sat, 12 Sep 2009 18:13:08 +0200
282
283fglrx-driver (1:9-8-2) unstable; urgency=low
284
285  [ Bertrand Marc ]
286  * Remove old hackish lines in fglrx-glx.postrm (Closes: #542400).
287  * Source /lib/lsb/init-functions in fglrx-atieventsd.init to get
288    log_warning_msg function.
289    Closes: #543946
290  * Make fglrx-atieventsd depends on lsb-base to ensure the presence of
291    /lib/lsb/init-functions.
292
293  [ Patrick MatthÀi ]
294  * Add acpid to recommends of fglrx-atieventsd, it is mostly useless without
295    the acpi daemon.
296  * Remove all hackish diversion handlings.
297  * Remove deprecated conffile /etc/init.d/fglrx-driver, so insserv is happy.
298    Closes: #543384
299  * Sync uploaders of the control template with the original one.
300  * Remove unused orphaned-diversion lintian overrides from fglrx-glx.
301
302 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 27 Aug 2009 18:40:15 +0200
303
304fglrx-driver (1:9-8-1) unstable; urgency=high
305
306  * New upstream release.
307    - The invalid map errors should be gone now.
308      Closes: #524871
309    - Add new lintian overrides for crappy code.
310    - Drop 04-irq_return_2.6.30.dpatch, we do not need it anymore.
311    - 05-missing-pci_enable_msi.dpatch, we do not need it anymore.
312    - 08-config_x86_32.dpatch, we do not need it anymore.
313    - 07-preempt-fix.dpatch, we do not need it anymore.
314    - 02-2.6.29-support.dpatch, we do not need it anymore.
315    - 06-missing-flush_tlb.dpatch, we do not need it anymore.
316  * Bump Standards-Version to 3.8.3.
317    - Add debian/README.source.
318  * Switch back to the fglrx-glx-ia32 package, ia32-apt-get has been removed
319    from the archive.
320    Closes: #538889
321  * Add conflicts again ia32-fglrx-driver and ia32-fglrx-glx.
322  * Add lintian overrides for orphaned diversions, which are handled by out
323    maintainer scripts.
324
325 -- Patrick MatthÀi <pmatthaei@debian.org>  Tue, 18 Aug 2009 09:37:40 +0200
326
327fglrx-driver (1:9-7-2) unstable; urgency=low
328
329  * Fix clashing diversions with installed ia32 packages. Thanks to
330    Sebastian Lipponer for testing the new changesets.
331    Closes: #538889
332  * Remove diversions set from the ia32 packages on removing fglrx.
333  * Remove unused lintian overrides for package fglrx-glx.
334
335 -- Patrick MatthÀi <pmatthaei@debian.org>  Sat, 01 Aug 2009 19:37:05 +0200
336
337fglrx-driver (1:9-7-1) unstable; urgency=low
338
339  * New upstream release.
340  * Fix provides in fglrx-atievents init script.
341    Closes: #538957
342  * Add fglrx-atieventsd.README.selinux which describes some steps to avoid
343    problems with atieventsd on SELinux.
344    Closes: #514061
345  * Refresh lintian overrides (drop some more and add one new).
346  * Also add ia32-apt-get support for fglrx-driver, which is also experimental
347    and as broken as ia32-fglrx-glx, because of the good ia32-apt-get design..
348    Closes: #538658
349
350 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 30 Jul 2009 10:22:25 +0200
351
352fglrx-driver (1:9-6-4) unstable; urgency=low
353
354  [ Debian l10n ]
355  * Add galician translation from Marce.
356    Closes: #537537
357
358  [ Patrick MatthÀi ]
359  * Drop fglrx-glx-ia32 package and add some workarounds, so that it works with
360    ia32-apt-get.
361    Closes: #537958
362  * Remove the deprecated x6* directorys in the get-orig-source from the
363    tarball. They just blow up the orig.tar.gz.
364
365 -- Patrick MatthÀi <pmatthaei@debian.org>  Thu, 23 Jul 2009 18:04:52 +0200
366
367fglrx-driver (1:9-6-3) unstable; urgency=low
368
369  * Add 08-config_x86_32 patch from Gentoo, it fixes a build error on X86_32.
370  * Add 07-preempt-fix from Gentoo, which disables preempt if it is enabled.
371  * Add 06-missing-flush_tlb patch from Gentoo, which fixes the flush_tlb
372    symbol error on loading the fglrx module.
373    Closes: #535152
374  * Rediff hunky 02-2.6.29-support patch.
375
376 -- Patrick MatthÀi <pmatthaei@debian.org>  Tue, 30 Jun 2009 20:04:29 +0200
377
378fglrx-driver (1:9-6-2) unstable; urgency=low
379
380  * Add cherry taken 05-missing-pci_enable_msi patch from archlinux, which adds
381    a missing symbol.
382    Closes: #534927
383  * Rename fglrx-atieventsd.fglrx-driver.init to fglrx-atieventsd.init and
384    remove the name parameter from dh_installinit. This also renames the
385    fglrx-driver init script to fglrx-atieventsd.
386    Closes: #534996
387
388 -- Patrick MatthÀi <pmatthaei@debian.org>  Mon, 29 Jun 2009 22:09:35 +0200
389
390fglrx-driver (1:9-6-1) unstable; urgency=low
391
392  [ Debian l10n ]
393  * Add czech translation from Tomas Fidler.
394    Closes: #533093
395
396  [ Patrick MatthÀi ]
397  * New upstream release.
398    Closes: #533750
399    - The map error should be gone away now.
400      Closes: #524871
401    - Fix for the inversed colors in some games.
402      Closes: #523746
403  * Move all files from /emul/ to /usr/lib32/.
404    Closes: #533225
405  * Add default file for fglrx-atieventsd and modify the init script, so that
406    the daemon could be disabled about the default file.
407    Closes: #532238
408  * Bump Standards-Version to 3.8.2 (no changes needed).
409  * Remove dh_desktop, fixes lintian warning dh_desktop-is-deprecated.
410  * Add source.lintian-overrides and override all prebuilt binary warnings.
411  * We have to pre-depend now on libc6-i386 (>= 2.9-18) for the well planed
412    transition.
413  * Add warning to long-description of fglrx-driver and to README.Debian that
414    fglrx replaces parts of the X11/Mesa system.
415    Closes: #534183
416  * Add 04-irq_return_2.6.30.dpatch which fixes a FTBFS with Linux 2.6.30.
417    Closes: #534762
418  * Replace my old email address in the control template.
419  * Bump build dependency on ia32-libs on amd64 to >> 2.7.
420
421 -- Patrick MatthÀi <pmatthaei@debian.org>  Sat, 27 Jun 2009 10:14:39 +0200
422
423fglrx-driver (1:9-5-1) unstable; urgency=low
424
425  * New upstream release.
426  * Override some more lintian warnings in package fglrx-glx.
427
428 -- Patrick MatthÀi <pmatthaei@debian.org>  Tue, 19 May 2009 19:25:21 +0200
429
430fglrx-driver (1:9-4-2) unstable; urgency=low
431
432  * Change my email address.
433  * Remove DM-Upload-Allowed control field.
434  * Add lintian overrides for the most warnings, which will never be fixed by
435    AMD or are just wrong.
436  * Describe in 02-2.6.29-support.dpatch, that it should be disabled if another
437    Linux version as 2.6.29 should be used with fglrx.
438  * Extend long description of fglrx-source and fglrx-kernel-src, fixes lintian
439    warning extended-description-is-probably-too-short.
440
441 -- Patrick MatthÀi <pmatthaei@debian.org>  Wed, 06 May 2009 16:03:56 +0200
442
443fglrx-driver (1:9-4-1) unstable; urgency=low
444
445  * New upstream release.
446    - Warning: This release does not support anymore any chips below the
447      r600 series. If you have a r1xx-r5xx chip, please use the radeon or
448      radeonhd driver instead.
449    - aticonfig does not fail anymore on configuring newer cards.
450      Closes: #522027
451    - fglrx works now with newer libdrm version.
452      Closes: #521323
453    - Support for newer xserver-xorg versions.
454      Closes: #523833
455    - Fix for incorrect colour displaying.
456      Closing: #523746
457    - This release only supports r6xx and r7xx cards. So note this in the
458      packages short description.
459    - Drop 04-macro_fix-flush_tlb_page.dpatch. It is not needed anymore.
460  * Add 02-2.6.29-support.dpatch which adds a hack to support Linux 2.6.29.
461    Closes: #521164
462  * Remove svn:executable on debian/amdcccle.xpm. This fixes lintian warning
463    executable-not-elf-or-script. Thanks.
464
465 -- Patrick MatthÀi <patrick.matthaei@web.de>  Sat, 18 Apr 2009 09:33:54 +0200
466
467fglrx-driver (1:9-3-1) unstable; urgency=low
468
469  * New upstream release.
470    This is the last release which supports r300-r500 chips.
471  * Fix override disparity. fglrx-source is now non-free/kernel.
472
473 -- Patrick MatthÀi <patrick.matthaei@web.de>  Sun, 29 Mar 2009 21:41:41 +0200
474
475fglrx-driver (1:9-2-3) unstable; urgency=low
476
477  [ Patrick MatthÀi ]
478  * Adjust debian/watch to match with the new AMD homepage.
479  * Bump Standards-Version to 3.8.1 (no changes needed).
480  * Add new AMD Stream libraries.
481    Closes: #520480
482  * Simplify describe in README.Debian how to build the fglrx module and
483    enabling 3d acceleration support.
484    Closes: #516231
485  * Add some new sharedobject-in-library-directory-missing-soname lintian
486    overrides for the new libraries.
487  * Add new lintian override for fglrx-control about the embedded zlib in
488    amdcccle, we could not do anything against it.
489
490  [ Debian l10n ]
491  * Add japanese translation from Hideki Yamane.
492    Closes: #520065
493
494 -- Patrick MatthÀi <patrick.matthaei@web.de>  Tue, 24 Mar 2009 19:10:25 +0200
495
496fglrx-driver (1:9-2-2) unstable; urgency=low
497
498  * Add 04-macro_fix-flush_tlb_page.dpatch cherry taken from Arch Linux.
499    Closes: #517545
500
501 -- Patrick MatthÀi <patrick.matthaei@web.de>  Wed,  4 Mar 2009 11:17:25 +0200
502
503fglrx-driver (1:9-2-1) unstable; urgency=low
504
505  [Bertrand Marc]
506  * New upstream release.
507    Closes: #516818
508  * Update README.hacking to match odd ATI versionning system.
509
510  [ Debian l10n ]
511  * Add french translation from Christian Perrier.
512    Closes: #516536
513
514 -- Patrick MatthÀi <patrick.matthaei@web.de>  Tue, 24 Feb 2009 18:39:19 +0200
515
516fglrx-driver (1:9-1-2) unstable; urgency=low
517
518  [ Patrick MatthÀi ]
519  * Implement debconf question for ACPI switching.
520  * Backport it again for xserver-xorg < 7.4. We are uploading to unstable and
521    the xserver version in experimental is not compatibile with fglrx yet.
522  * Add notes about the low resolution bug if you are upgrading from fglrx
523    versions <= 8.7 in README.Debian.
524    Closes: #513208
525  * Fix debhelper-but-no-misc-depends.
526    Thanks lintian.
527  * Fix duplicate short descriptions.
528
529  [ Debian l10n ]
530  * Add swedish translation from Martin Ågren.
531    Closes: #512853
532  * Add russian translation from Yuri Kozlov.
533  * Add portuguese translation from Américo Monteiro.
534  * Add italian translation from Vincenzo Campanella.
535  * Add vietnamese translation from Clytie Siddall.
536    Closes: #513807
537  * Add german translation from Helge Kreutzmann.
538
539 -- Patrick MatthÀi <patrick.matthaei@web.de>  Thu, 19 Feb 2009 11:36:51 +0200
540
541fglrx-driver (1:9-1-1) experimental; urgency=low
542
543  * New upstream release.
544    - Add new build dependencie libxinerama-dev.
545
546 -- Patrick MatthÀi <patrick.matthaei@web.de>  Tue,  3 Feb 2009 18:24:49 +0200
547
548fglrx-driver (1:8-12-4) unstable; urgency=low
549
550  * Backport dependencies down to the xserver-xorg 7.1.0 release, so we can
551    upload to unstable.
552  * Add amdcccle.menu for unified Debian menu support.
553  * Fix lintian warning dh-clean-k-is-deprecated.
554  * Direct install of atieventsd.8 manpage.
555  * Install our own amdcccle.desktop.
556    Thanks to Rainer Trusch for spotting some more issues with the AMD one.
557
558 -- Patrick MatthÀi <patrick.matthaei@web.de>  Sun, 11 Jan 2009 17:35:02 +0200
559
560fglrx-driver (1:8-12-3) experimental; urgency=low
561
562  * Fix versioned dependency on xserver-xorg.
563
564 -- Patrick MatthÀi <patrick.matthaei@web.de>  Sun,  4 Jan 2009 12:57:41 +0200
565
566fglrx-driver (1:8-12-2) experimental; urgency=low
567
568  [ Patrick MatthÀi ]
569  * Add new diversion in fglrx-driver to libglx.so.
570    Closes: #510496
571  * Add README.Debian with backporting informations.
572  * Also describe in README.Debian, that "DefaultDepth 24" in xorg.conf is
573    needed for fglrx.
574    Closes: #460241
575  * Remove diversions of package fglrx-driver on remove.
576  * Bump dependencies to match with the xserver-xorg 7.4 release.
577  * Also fix the clashing diversions in fglrx-glx-ia32.preinst.
578
579  [ Romain Beauxis ]
580  * Tightened diversion removal in fglrx-glx to only libGL.so related
581    diversions.
582    Closes: #475007
583
584 -- Patrick MatthÀi <patrick.matthaei@web.de>  Sat,  3 Jan 2009 13:04:47 +0200
585
586fglrx-driver (1:8-12-1) experimental; urgency=low
587
588  * New upstream release. Closes: #508819
589    - No more dri problems like in the 8-11 release.
590      Closes: #506000
591    - It should build fine now with Linux 2.6.27.
592      Closes: #496318
593    - Remove deprecated patches.
594      Closes: #508024
595    - This release fixes some crashes on starting/playing videos with players
596      like kaffeine and mplayer.
597      Closes: #489254
598    - Remove 13-fix_debian_485605.patch which is fixed in this release.
599  * Add myself to uploaders.
600  * Add DM-Upload-Allowed control flag.
601  * Install the x740 libs, so fglrx could be used with xserver 1.5. If you
602    still use xserver < 1.5 then you have to set it back to x710 in
603    debian/rules.
604  * Fixed bashishm in the acpi fglrx-powermode.sh script.
605    Closes: #489575
606  * Remove fuzzy 14-deletes_unecessary_spaces.patch.
607  * Adjust path to index.html in README.hacking.
608  * Add missing ${misc:Depends}. Thanks lintian.
609  * Remove odd debian/TODO.
610  * Fit debian/README.hacking to the up to date and easy orig-source-target
611    to build the original tarball.
612  * Change to dpatch instead of a self-hackish one and migrate the patches
613    to it.
614  * Correct typo in debian/rules PHONY.
615  * Bump debhelper compatibility level to 7, so we can use dh_lintian.
616  * Override shlib-with-executable-stack lintian warning.
617  * Change short descriptions to also supporting r7xx cards in this version.
618
619 -- Patrick MatthÀi <patrick.matthaei@web.de>  Thu,  1 Jan 2009 17:17:02 +0200
620
621fglrx-driver (1:8-10-1) experimental; urgency=low
622
623  [ Bertrand Marc ]
624  * New upstream release. Closes: #500077
625  * Fixed corruption with windows wider than 1760
626    pixels. Closes: #450426
627  * Fixed AGP Aperture Size in BIOS. Closes: #451973
628  * Fixed double free corruption when running fglrxinfo
629    or any 3d apps. Closes: #454751
630  * Fixed corruption with Xvideo overlay. Closes: #361694
631  * Fixed DRI init and CMMQS driver init. Closes: #464667
632  * Fixed failure with fglrxinfo. Closes: #497543
633    thanks to Patrick Matthaei for testing these old bugs.
634
635  [ Romain Beauxis ]
636  * Set distribution to experimental for now.
637
638 -- Romain Beauxis <toots@rastageeks.org>  Tue, 11 Nov 2008 15:55:54 +0100
639
640fglrx-driver (1:8-7-3) unstable; urgency=low
641
642  * Updated patch for authatieventsd.sh, fixes authentification
643    issues and missing dependency. Thanks to Luca Niccoli !
644  Closes: #503878
645
646 -- Romain Beauxis <toots@rastageeks.org>  Sat, 08 Nov 2008 18:11:19 +0100
647
648fglrx-driver (1:8-7-2) unstable; urgency=low
649
650  * Fixed compilation with 2.6.26 kernels,
651    thanks to Deng Xiyue for reporting and
652    preparing the patch. Closes: #485793
653  * Removed last kernel-src bits from fglrx-source
654
655 -- Romain Beauxis <toots@rastageeks.org>  Fri, 25 Jul 2008 09:56:52 +0200
656
657fglrx-driver (1:8-7-1) experimental; urgency=low
658
659  [ Bertrand Marc ]
660  * New upstream release.
661
662  [ Romain Beauxis ]
663  * Target experimental for upload now that lenny freeze
664    occurs very soon.
665
666 -- Romain Beauxis <toots@rastageeks.org>  Fri, 25 Jul 2008 09:34:02 +0200
667
668fglrx-driver (1:8-6-2) unstable; urgency=low
669
670  * Fix "Unknown symbol flush_tlb_page", thanks to
671    Enrico Rossi for reporting and patching
672    Closes: #485605
673
674 -- Romain Beauxis <toots@rastageeks.org>  Wed, 02 Jul 2008 11:48:27 +0200
675
676fglrx-driver (1:8-6-1) unstable; urgency=low
677
678  [ Romain Beauxis ]
679  * Changed fglrx-kernel-src package architecture to all.
680
681  [ Bertrand Marc ]
682  * New upstream release.
683  * Virtual package renamed fglrx-modules to work with
684    linux-modules-nonfree.
685
686 -- Bertrand Marc <beberking@gmail.com>  Tue, 19 Jun 2008 16:56:14 +0200
687
688fglrx-driver (1:8-5-1) unstable; urgency=low
689
690  [ Bertrand Marc ]
691  * New upstream release (Closes: #483131).
692  * Fixed crashing Xorg when shutting down (Closes: #418338).
693  * Kernel module builds on Linux-2.6.25 (Closes: #476844).
694  * Build atieventsd into a separate package (Closes: #401559).
695  * Rename fglrx-kernel-src into fglrx-source to provide
696    compatibility with linux-modules-nonfree.
697
698  [ Romain Beauxis ]
699  * Patched authatieventsd.sh to fix xauth rights when using atieventsd
700  Thanks to Luca Niccoli for testing and providing a patch.
701  Closes: #418338
702  * Cleaned build dependencies
703
704 -- Romain Beauxis <toots@rastageeks.org>  Tue, 27 May 2008 14:32:04 +0200
705
706fglrx-driver (1:8-4-1) unstable; urgency=low
707
708  [ Bertrand Marc ]
709  * New upstream release
710
711  [ Romain Beauxis ]
712  * Kernel module's version hasn't changed since last release,
713    so now using the marketing versioning for the package.
714  * Some bugs concerning black screen on logout were fixed, though
715    I couldn't indentify with certainty if some of the bugs in our
716    BTS were fixed. Please review and fix if you can !
717
718 -- Romain Beauxis <toots@rastageeks.org>  Thu, 17 Apr 2008 16:56:01 +0200
719
720fglrx-driver (8.47.3-3) unstable; urgency=low
721
722  * Previous fix was not complete. Now the package builds on i386..
723  Thanks to Bálint Réczey and Sedat Dilek again..
724  Closes: #471334
725
726 -- Romain Beauxis <toots@rastageeks.org>  Sun, 16 Mar 2008 03:19:12 +0100
727
728fglrx-driver (8.47.3-2) unstable; urgency=low
729
730  * Fixed compilation with 386 architectures:
731    splited dh_gencontrol invokations.
732  Thanks to Sedat Dilek for reporting and testing.
733
734 -- Romain Beauxis <toots@rastageeks.org>  Sun, 16 Mar 2008 03:13:39 +0100
735
736fglrx-driver (8.47.3-1) unstable; urgency=low
737
738  * New upstream release
739  Closes: #469562
740  * Changed maintainer and uploaders fields to reflect new team.
741  * Switched to svn.debian.org, added corresponding headers in debian/control
742  * Added a fglrx-glx-ia32 for amd64, with 32 bit libGL. Recommending the
743    package in fglrx-driver.
744  Closes: #462362, #469962
745
746 -- Romain Beauxis <toots@rastageeks.org>  Thu, 06 Mar 2008 02:00:34 +0100
747
748fglrx-driver (8.45.5-1) unstable; urgency=low
749
750  * New "valentine's" release.
751  * Added a fglrx-glx package to install fglrx's private libGL
752    Closes: #463723, #451119
753  * First GL application no longer freezes
754    Closes: #460237
755
756 -- Romain Beauxis <toots@rastageeks.org>  Thu, 14 Feb 2008 14:21:04 +0100
757
758fglrx-driver (8.45.4-1) unstable; urgency=low
759
760  * New upstream release
761  * Widescreen resolutions fixed
762    Closes: #457298
763  * Support suspend on latest kernels
764    Closes: #402273
765  * Support custom modelines
766    Closes: #459852
767  * Updated standards to 3.7.3
768
769 -- Romain Beauxis <toots@rastageeks.org>  Fri, 18 Jan 2008 16:18:56 +0100
770
771fglrx-driver (8.43.2-2) unstable; urgency=low
772
773  * Updated package description:
774    + Removed supported cards list, this was misleading and broken
775      from one release to another
776    + Written excplicitly that radeonhd is a possible alternative
777  * Updated README.Debian:
778    + Removed 3D acceletation tweaking, they were outdated for
779      recent versions that use plain mesa
780    + Added workaround for screen corruption (Closes: #449117)
781
782 -- Romain Beauxis <toots@rastageeks.org>  Wed, 05 Dec 2007 16:16:08 +0100
783
784fglrx-driver (8.43.2-1) unstable; urgency=low
785
786  * New upstream release
787  * Marketing naming and versioning. Keeping original names,
788    and using module's claimed version, 8.43.2.
789  * Droped 2.6.23 support patch, fixed upstream
790
791 -- Romain Beauxis <toots@rastageeks.org>  Thu, 22 Nov 2007 13:45:43 +0100
792
793fglrx-driver (8.42.3-3) unstable; urgency=low
794
795  * Fixed dpkg-divert removal calls.
796    Remove any diversion that's refering to fglrx.
797  * Added basic patch to support all hardware.
798    Please note that this is a trivial patch that only
799    add pci ids to the module list. Not *any* waranty that
800    this will make *your* special fireGL card work.
801    For strong support, please bug upstream and wait for new releases...
802  * Added missing XS-Autobuild: yes to debian/control and notice in
803    debian/copyright
804  * Changed maintainer from binary module package templates.
805
806 -- Romain Beauxis <toots@rastageeks.org>  Mon, 12 Nov 2007 12:05:03 +0100
807
808fglrx-driver (8.42.3-2) unstable; urgency=low
809
810  * Upload to unstable. Release does not seem good, but at least it works.
811  * Added instruction to get XV driver work with this release.
812  * Module build fixed for 2.6.23. It was applied with last release, but I
813    forgot to close.. (Closes: #446967)
814  * Compatibility with standard mesa GL support is confirmed on my machine.
815    (Closes: #401584)
816
817 -- Romain Beauxis <toots@rastageeks.org>  Mon, 29 Oct 2007 14:35:48 +0100
818
819fglrx-driver (8.42.3-1) experimental; urgency=low
820
821  * New upstream release (Closes: #447854, #442092)
822  * Works with latest X.org packages (Closes: #443129)
823  * Support for AIGLX (Closes: #391279)
824  * Updated package descriptions (Closes: #446678)
825  * Removed custom libGL and devel package as it seems to be built
826    upon standard libGL.
827
828 -- Romain Beauxis <toots@rastageeks.org>  Wed, 24 Oct 2007 13:38:40 +0200
829
830fglrx-driver (8.40.4-2) unstable; urgency=low
831
832  * Added signature and control files to remove watermark issue,
833  thanks to Soeren Sonnenburg.
834  Closes: #434736
835
836 -- Romain Beauxis <toots@rastageeks.org>  Wed, 15 Aug 2007 13:07:58 +0200
837
838fglrx-driver (8.40.4-1) experimental; urgency=low
839
840  * New upstream release
841  * Not fixed watermark issue, hence upload to experimental..
842
843 -- Romain Beauxis <toots@rastageeks.org>  Wed, 15 Aug 2007 03:29:09 +0200
844
845fglrx-driver (8.39.4-1) experimental; urgency=low
846
847  * New upstream release
848  * Upload to experimental because of a nasty
849  watermark bug, see:
850    http://www.phoronix.com/?page=news_item&px=NTkwNg
851  * Module will now build against a 2.6.22 kernel
852  (paravirt_ops is not only GPL on this kernel)
853  Closes: #420842
854  * Added dummy fglrx-amdcccle package for
855  compatibility with ATI's packages.
856  Closes: #430962
857  * Removed debian/rules clean call in module's
858  kdist_image target. (Closes: #431134)
859  * Removed patch for ioctl32.h: applied upstream.
860
861 -- Romain Beauxis <toots@rastageeks.org>  Fri, 20 Jul 2007 14:07:31 +0200
862
863fglrx-driver (8.38.6-2) unstable; urgency=low
864
865  * Added back new catalyst control panel.
866
867 -- Romain Beauxis <toots@rastageeks.org>  Thu, 28 Jun 2007 15:41:58 +0200
868
869fglrx-driver (8.38.6-1) experimental; urgency=low
870
871  * New upstream release
872  * Commented out fglrx-control until
873    I find out where it has gone...
874    If this removal is intentional, build-deps
875    have to ble cleaned too.
876  * Regenerated 00-make.sh patch
877  * Added ioctl32_fix.diff (Closes: #428527)
878  * Updated man pages, thanks to
879    Daniel Leidert (Closes: #402383)
880  * Changed fglrx-driver.preinst to avoid using
881    /var/lib/dpkg/status directly (thanks to lintian)
882  * Changed ${Source-Version} to ${binary:Version}
883    in debian/control (again thanks to lintian...)
884
885 -- Romain Beauxis <toots@rastageeks.org>  Tue, 26 Jun 2007 15:15:16 +0200
886
887fglrx-driver (8.37.6-1) unstable; urgency=low
888
889  * New upstream release
890  * get-orig-source rule (Closes: #409732)
891  * upstream corrected version check (Closes: #420174)
892
893 -- Romain Beauxis <toots@rastageeks.org>  Fri, 01 Jun 2007 14:07:15 +0200
894
895fglrx-driver (8.36.5-1) experimental; urgency=low
896
897  * New upstream release. Closes: #412007
898  * Added myself as uploader, with Flavio's agreement.
899
900 -- Romain Beauxis <toots@rastageeks.org>  Tue, 24 Apr 2007 12:18:25 +0200
901
902fglrx-driver (8.34.8-1) experimental; urgency=low
903
904  * New upstream version. (Closes: #412007, #412106)
905
906  * Highlights from the release notes:
907    - A system hang no longer occurs when attempting to resume from
908      hibernation mode.
909    - Loading the XVideo Extension on 64-bit Xorg 6.9+ systems no longer
910      results in the X Server segfaulting when launching.
911      This issue was known to occur with Radeon X1K products.
912    - Running aticonfig--dtop=(horizontal|vertical) no longer results in clone
913      mode being activated when attempting to enable big desktop mode.
914    - Switching between X Server and text console mode no longer results in
915      a system failing to respond. [fixed in version 8.32.5]
916      (? maybe closes #402375 and maybe also #345040 ?)
917
918  * Drop list of supported chipsets, because the driver doesn't list them in
919    the X server log file any more.
920
921  * Add patch 20-fglrx-8.34.8-for-2.6.20 to support kernel 2.6.20;
922    thanks to "Whoopie" for the patch and to Soeren for the link.
923
924  * Fix the kernel module's debian/rules to let it understand --rootcmd;
925    thanks to Eric Cooper for the patch.
926    (Closes: #364528)
927
928  * Update man pages as of 2006-12-15, matching version 8.28.8; the license
929    was rewritten, without significant changes in the rights granted.
930
931 -- Flavio Stanchina <flavio@stanchina.net>  Sat, 24 Feb 2007 01:24:10 +0100
932
933fglrx-driver (8.31.5-1) experimental; urgency=low
934
935  * New upstream version. (Closes: #399136, #399301)
936    - Update list of supported cards.
937
938  * Add patch 12-CONFIG_X86_XEN to allow building on Xen-enabled kernels;
939    thanks to Loic Minier.
940    (Closes: #368802)
941
942  * Add patch 13-config_h-is-gone to allow building on Linux 2.6.19-rc2:
943    linux/config.h is no longer generated, include linux/autoconf.h instead;
944    thanks to Julien BLACHE.
945    (Closes: #398980)
946
947 -- Flavio Stanchina <flavio@stanchina.net>  Sun, 19 Nov 2006 17:29:05 +0100
948
949fglrx-driver (8.30.3-1) experimental; urgency=low
950
951  * New upstream version. (Closes: #388794)
952    - Move conffiles from /etc to /etc/ati to match upstream.
953    - Update list of supported cards.
954
955 -- Flavio Stanchina <flavio@stanchina.net>  Thu,  2 Nov 2006 23:56:01 +0100
956
957fglrx-driver (8.28.8-3) unstable; urgency=low
958
959  * Explicitly call moc-qt3, not just moc, when building the control panel.
960    Fixes FTBFS when qt4-dev-tools is installed and moc-qt4 is the default.
961    (Closes: #389504; really closes #383974 which was the same bug)
962
963  * /etc/acpi/fglrx-powermode.sh tried to source /etc/default/fglrx, but the
964    file we actually install is /etc/default/fglrx-driver.
965    (Closes: #389744)
966
967  * Changes to the README of fglrx-driver:
968    - Add link to http://dri.freedesktop.org/wiki/DriTroubleshooting
969    - Add a note about http://bugs.debian.org/384325
970
971 -- Flavio Stanchina <flavio@stanchina.net>  Thu,  2 Nov 2006 00:26:39 +0100
972
973fglrx-driver (8.28.8-2) unstable; urgency=low
974
975  * Acknowledge NMUs by Chris Hanson. Thanks!
976    (Closes: #382038, #388812, #388840)
977
978  * Change fglrx-driver's dependencies and description to match the switch to
979    X.Org version 7.1.
980
981  * Switch to debhelper >= 5, no changes. Actually done in 8.28.8-1, but it
982    wasn't recorded in the changelog due to a slight error by my sponsor.
983
984  * Build the man pages from source again now that Daniel's NMU of docbook-xsl
985    1.70.1 has entered testing.
986
987  * Reorder installation methods in the fglrx-kernel-src documentation; thanks
988    to Ted Percival for the patch.
989    (Closes: #384175)
990
991  * Un-capitalize the first letter of short descriptions.
992  * Remove useless installation instructions from the docs.
993  * Update list of supported cards.
994  * Style fixes to debian/acpi/fglrx-powermode.sh.
995  * Clean up debian/TODO.
996
997 -- Flavio Stanchina <flavio@stanchina.net>  Mon, 25 Sep 2006 01:28:23 +0200
998
999fglrx-driver (8.28.8-1.2) unstable; urgency=low
1000
1001  * NMU
1002  * debian/control: change "Recommends: fglrx-kernel" to "Recommends:
1003    fglrx-kernel-src | fglrx-kernel" to fix debcheck warning.
1004
1005 -- Chris Hanson <cph@debian.org>  Sat, 23 Sep 2006 13:31:12 -0400
1006
1007fglrx-driver (8.28.8-1.1) unstable; urgency=low
1008
1009  * NMU
1010  * debian/rules: use Xorg 7.1 binaries.
1011    (closes: Bug#382038, Bug#388812, Bug#388840)
1012  * debian/control: change "Provides: xserver-xorg-video" to "Provides:
1013    xserver-xorg-video-1.0".
1014  * debian/rules, debian/fglrx-driver.manpages: decompress atievents.8 man
1015    page in order to eliminate lintian error.
1016  * debian/fglrx-driver.init: add LSB section to eliminate lintian
1017    warning.
1018
1019 -- Chris Hanson <cph@debian.org>  Fri, 22 Sep 2006 21:45:56 -0400
1020
1021fglrx-driver (8.28.8-1) unstable; urgency=low
1022
1023  [ Flavio Stanchina ]
1024  * Acknowledge NMU; adding changes of unreleased versions for history.
1025    (Closes: #355485, #366564, #375001, #378496, #383974)
1026
1027  * Close remaining "new upstream version available" bugs.
1028    (Closes: #369039, #369043)
1029
1030  * Standards-Version: 3.7.2
1031
1032  * Change debian/rules and debian/control to hardcode X implementation and
1033    version. Now we just depend on X.Org version 7.0 and above.
1034
1035  * Update man pages. Daniel Leidert, the manpages maintainer, says Debian's
1036    docbook stuff is hopelessly outdated, so I'm using precompiled man pages
1037    provided by Daniel instead of building them from the DocBook sources.
1038    Therefore, also remove the docbook stuff from the build dependencies.
1039    (Closes: #360819, #360822, #369627)
1040
1041  * Patch firegl-public.c to use CONFIG_SMP rather than a custom macro defined
1042    by make.sh, as that script is not called when building with Linux 2.6.
1043    (Closes: #364762)
1044
1045  * fglrx-driver provides xserver-xorg-video.
1046    (Closes: #365015, #385680)
1047
1048  * Clean up debian/NEWS and debian/TODO.
1049
1050  [ Chris Hanson ]
1051  * Add atieventsd and associated ACPI files.
1052  * Fix lintian errors:
1053    - debian/control: Add pre-depends on x11-common.
1054    - debian/fglrx-driver.shlibs: Update for changed libs.
1055
1056 -- Flavio Stanchina <flavio@stanchina.net>  Sat,  9 Sep 2006 14:05:04 +0200
1057
1058fglrx-driver (8.28.8-0.1) unstable; urgency=low
1059
1060  * Non-maintainer upload to get some of the worst issues fixed. Thanks to
1061    Marco von Zwetselaar for doing most of the preliminary grunt work.
1062  * New upstream version.
1063    * Fixes issues with kernel panics. (Closes: #366564, #355485)
1064    * Fixes FTBFS with newer kernels. (Closes: #378496, #375001)
1065    * Fixes FTBFS with newer Qt. (Closes: #383974)
1066    * Adapted patches 00-make.sh and 02-Makefile for the new source versions
1067      (taken directly from Marco's packages).
1068    * Removed obsolete patches 22-intermodule and 23-noiommu (integrated into
1069      upstream, fixes issues with newer kernels).
1070
1071 -- Steinar H. Gunderson <sesse@debian.org>  Sat, 26 Aug 2006 02:14:54 +0200
1072
1073fglrx-driver (8.27.10-1) UNRELEASED; urgency=low
1074
1075  * New upstream version. Thanks to Chris for the patch.
1076    - Fixes kernel module compilation problems with Linux 2.6.17.
1077
1078 -- Flavio Stanchina <flavio@stanchina.net>  Thu,  3 Aug 2006 23:06:00 +0200
1079
1080fglrx-driver (8.26.18-1) UNRELEASED; urgency=low
1081
1082  * New upstream version.
1083
1084  * Highlights from the release notes:
1085    - Hotplug Support for Digital Flat Panels.
1086    - Thermal Event Power Management.
1087
1088 -- Flavio Stanchina <flavio@stanchina.net>  Mon, 26 Jun 2006 17:42:25 +0200
1089
1090fglrx-driver (8.25.18-1) UNRELEASED; urgency=low
1091
1092  * New upstream version.
1093
1094  * Highlights from the release notes:
1095    - Support for the FireGL V2200, V3350, V3400, V5200, V7200, V7300, V7350.
1096    - The internal AGP GART is no longer provided.
1097
1098  * Bugs fixed upstream:
1099    - Running two X servers simultaneously no longer results in the system
1100      failing to respond.
1101    - Toggling between console mode and X Server graphical mode no longer
1102      results in a system hang.
1103    - Attempting to enable clone mode or extended desktop mode no longer
1104      results in the secondary display device failing to activate when using
1105      the ATI Control Panel.
1106
1107 -- Flavio Stanchina <flavio@stanchina.net>  Mon, 29 May 2006 11:00:09 +0200
1108
1109fglrx-driver (8.24.8-1) unstable; urgency=low
1110
1111  * New upstream version.
1112    (Closes: #362557)
1113
1114  * X.Org 7.0 support.
1115    (Closes: #362087, #362278, #362485)
1116
1117  * Add patches from Gentoo to support kernel 2.6.16:
1118    - debian/patches/22-intermodule.patch
1119    - debian/patches/23-noiommu.patch
1120    [thanks to Joerg (aka Kano) for the links]
1121
1122  * Add file "fglrx-supported.txt" to the fglrx-driver documentation: it's a
1123    complete list of the chipsets supported by the fglrx driver, as reported
1124    by the driver itself in the X.Org log file.
1125
1126  * Split README.Debian: the part about building the kernel module goes into
1127    the fglrx-kernel-src package. While we're at it, expand said part by
1128    picking from the instructions of my old unofficial packages.
1129    (Closes: #343932)
1130
1131  * Remove rpm from the build dependencies as it is not needed anymore.
1132
1133 -- Flavio Stanchina <flavio@stanchina.net>  Tue, 18 Apr 2006 00:01:11 +0200
1134
1135fglrx-driver (8.23.7-1) unstable; urgency=low
1136
1137  [ Flavio Stanchina ]
1138  * New upstream version. Highlights from the release notes:
1139    - OpenGL 2.0 Enhancement
1140    - Full Scene Anti-Aliasing Support
1141    (Closes: #356135)
1142
1143  [ Steinar H. Gunderson ]
1144  * Fix typo in debian/man script, fixing FTBFS.
1145
1146 -- Steinar H. Gunderson <sesse@debian.org>  Sun, 19 Mar 2006 03:45:01 +0100
1147
1148fglrx-driver (8.22.5-1) UNRELEASED; urgency=low
1149
1150  * New upstream version.
1151    (Closes: #352487)
1152  * Revamp the packaging scripts to pick the upstream files from an unpacked
1153    (and cleaned up) ATI installer's directory structure, which allows us to
1154    take advantage of the X.Org 6.9 binaries available therein.
1155    (Closes: #345755)
1156
1157 -- Flavio Stanchina <flavio@stanchina.net>  Mon, 27 Feb 2006 23:53:07 +0100
1158
1159fglrx-driver (8.21.7-1) UNRELEASED; urgency=low
1160
1161  * New upstream version. New features include OpenGL 2.0 support.
1162    (Closes: #349369)
1163  * Acknowledge NMU. Thanks Norbert!
1164    (Closes: #345040, #346173)
1165  * Add shlibs file to fix problem with diversion.
1166    (Closes: #343997)
1167  * Remove dummy file "debian/include/fglrx_pp_proto.h" because it's now
1168    shipped with the control panel's source code.
1169  * Update man pages.
1170
1171 -- Flavio Stanchina <flavio@stanchina.net>  Wed, 25 Jan 2006 12:00:26 +0100
1172
1173fglrx-driver (8.20.8-1.1) unstable; urgency=low
1174
1175  * Non-maintainer upload.
1176  * Added patch from http://lkml.org/lkml/2005/12/11/26 to get the driver
1177    working with recent kernels. (closes: #345040)
1178
1179 -- Norbert Tretkowski <nobse@debian.org>  Fri,  6 Jan 2006 20:29:35 +0100
1180
1181fglrx-driver (8.20.8-1) unstable; urgency=low
1182
1183  * New upstream version. Highlights from the release notes:
1184    - Attempting to resume from system suspension no longer results in the
1185      system failing to respond.
1186    - Kernel module compile issues with the stock 2.6.13 and 2.6.14 kernel are
1187      now resolved.
1188
1189  * Add support for amd64. The .orig.tar.gz file now contains the pristine
1190    upstream i386 and amd64 RPM files: this is less than ideal because we're
1191    shipping several megabytes of binary files we'll never use and two copies
1192    of the few files that are actually source code, but hand-picking only the
1193    files we actually use would be a tedious and error-prone process.
1194    (Closes: #341077)
1195    - Update copyright file accordingly.
1196    - Add build dependency on rpm.
1197
1198  * dpkg-divert can't move files between different filesystems. Therefore,
1199    divert libGL to a subdirectory of /usr/X11R6/lib rather than /usr/share:
1200    the latter can in fact be on a different filesystem, if I understand the
1201    FHS correctly. On amd64, the same reasoning applies to the diversion of
1202    the 32-bit libGL: keep it within /emul/ia32-linux.
1203    (Closes: #341458)
1204    - This change involves some trickery with dpkg-divert. I tested several
1205      upgrade and downgrade scenarios and I hope I got it right, but please
1206      keep an eye open for any mishaps.
1207    - While we're at it, libGL is not architecture-independent so placing it
1208      anywhere within /usr/share was incorrect anyway...
1209
1210  * Add dummy file "debian/include/fglrx_pp_proto.h" to be able to build the
1211    control panel's source code without patching it.
1212  * Don't ignore errors when building the control panel.
1213  * Add man pages from Daniel Leidert.
1214  * Set versioned dependency in the -dev package.
1215  * The driver suggests the control panel.
1216  * Fix handling of DEB_BUILD_OPTIONS:
1217    - let dh_strip handle "nostrip";
1218    - honor "noopt" and pass CFLAGS to sub-makes and gcc.
1219  * Make lintian happy (or at least happier):
1220    - remove unneeded extra license files;
1221    - add ldconfig symlinks for the shared libraries;
1222    - add overrides for a few problems we can't fix, at least for now.
1223  * Fix debian/rules to avoid installing CVS directories.
1224
1225 -- Flavio Stanchina <flavio@stanchina.net>  Tue, 13 Dec 2005 12:58:39 +0100
1226
1227fglrx-driver (8.19.10-1) unstable; urgency=low
1228
1229  * New upstream version. Highlights from the release notes:
1230    - PowerPlay(tm) Support
1231    - fgl_glxgears Update
1232    - Initial Suspend and Resume Support
1233    - The latest proprietary driver introduces a resolution for drmMap
1234      failures on 64bit NLD9 SP2 and 64bit Ubuntu Breezy distribution,
1235      resolving an issue that prevented 3D acceleration.
1236    [thanks to Alexandru for the patch]
1237  * Initial upload to Debian.
1238    - Include the complete license in debian/copyright.
1239    - Rename control panel package from fglrx-control-qt3 to fglrx-control.
1240    - Remove fglrx-sources package, it belongs in the source package.
1241  * Stop patching the control panel source code due to licensing issues; this
1242    is a workaround until ATI changes clause 1.d.vi of the license.
1243
1244 -- Flavio Stanchina <flavio@stanchina.net>  Thu, 17 Nov 2005 22:34:57 +0100
1245
1246fglrx-driver (8.18.8-1) experimental; urgency=low
1247
1248  * New upstream version (minor update).
1249  * Updated desktop file.
1250    [thanks to Daniel Leidert]
1251  * Remove call to QApplication::setStyle() from panel/main.cpp, because:
1252    - it was overriding the user's preferred window style;
1253    - it caused compilation errors in some cases.
1254    [thanks to Aaron for the patch]
1255  * Clean up the control panel's makefile; among other things, stop creating a
1256    bzipped copy of the panel binary that we don't use.
1257  * Moved binaries from usr/X11R6/bin to usr/bin.
1258  * Kernel 2.6.14 removes register_ioctl32_conversion() for AMD64.
1259  * Build-Depends on libstdc++5 because the prebuilt binaries require it.
1260
1261 -- Flavio Stanchina <flavio@stanchina.net>  Thu, 10 Nov 2005 21:55:02 +0100
1262
1263fglrx-driver (8.18.6-1) experimental; urgency=low
1264
1265  * New upstream version. Highlights from the release notes:
1266    - Dynamic Clock Gating
1267    - Enhanced Support for OpenGL Development
1268    - Dual Link Monitor Support
1269    - Xinerama Support
1270    - New X Server Configuration Utility
1271    [thanks to Alexandru for the patch]
1272  * Updated Build-Depends to handle both XFree86 and X.Org packages, as
1273    suggested by Michel DÀnzer and others.
1274  * Add --referer=ati.com to the wget command line.
1275
1276 -- Flavio Stanchina <flavio@stanchina.net>  Sat, 22 Oct 2005 16:05:04 +0200
1277
1278fglrx-driver (8.16.20-1) experimental; urgency=low
1279
1280  * New upstream version. Highlights from the release notes:
1281    - workstation performance improvement
1282    - improved display detection support
1283    - Linux 2.6.12 kernel support
1284    - GCC 4.0 support
1285
1286 -- Flavio Stanchina <flavio@stanchina.net>  Sat, 20 Aug 2005 11:08:25 +0200
1287
1288fglrx-driver (8.14.13-2) experimental; urgency=low
1289
1290  * debian/rules: run dh_shlibdeps with --exclude=emul to avoid errors on
1291    32-bit libraries when building the 64-bit packages.
1292    - We're not interested in 32-bit library dependencies anyway; users that
1293      want to run 32-bit applications should install ia32-libs separately.
1294
1295 -- Flavio Stanchina <flavio@stanchina.net>  Mon, 13 Jun 2005 11:42:23 +0200
1296
1297fglrx-driver (8.14.13-1) experimental; urgency=low
1298
1299  * New upstream version.
1300  * Create directory "usr/share/fglrx/diversions" in the preinst script again,
1301    because the package hasn't been unpacked yet at this point.
1302    - Unfortunately, due to what appears to be a bug in dpkg-divert, if you
1303      installed 8.12.10-2 from scratch rather than upgrading, it's very likely
1304      that the existing /usr/X11R6/lib/libGL.so.1.2 has been deleted. This has
1305      no consequences until the fglrx driver is installed, but if you remove
1306      it in the future, you'll need to reinstall xlibmesa-gl.
1307  * [amd64] AMD64 RPMs are in a different directory.
1308    [thanks to Alexandru for the hint]
1309  * [amd64] Patch libGL.so at package creation, not during build.
1310
1311 -- Flavio Stanchina <flavio@stanchina.net>  Sun, 12 Jun 2005 18:48:53 +0200
1312
1313fglrx-driver (8.12.10-2.1) experimental; urgency=low
1314
1315  * debian/control: also Build-Depend on libxtst-dev... Ooops...
1316
1317 -- Flavio Stanchina <flavio@stanchina.net>  Thu,  2 Jun 2005 23:33:27 +0200
1318
1319fglrx-driver (8.12.10-2) experimental; urgency=low
1320
1321  * debian/control: Build-Depend on x-dev and libx11-dev rather than the
1322    transitional xlibs-dev package.
1323  * debian/rules: remove no-longer-used $(README) target.
1324  * debian/rules: revamp build target to get rid of "build-stamp".
1325  * debian/rules: put directory "usr/share/fglrx/diversions" in the package
1326    rather than creating it in the preinst script.
1327  * debian/rules: run dh_strip to remove unneeded debug information.
1328  * debian/rules: removed --remove-files from the tar call because
1329    a) it's pointless, as it is followed by "rm -r modules" already and
1330    b) doesn't work with tar 1.15 that wants options before file names.
1331    [thanks to Eduard Bloch and others for noticing this]
1332  * debian/rules: compress the module tarball with bzip2 and name it
1333    "fglrx.tar.bz2"; update instructions accordingly.
1334    [thanks to Eduard Bloch for the suggestion]
1335  * module/rules: warn the user if the unpacked source doesn't match the
1336    installed fglrx-kernel-src package's version.
1337  * module/control.template: upgrade Recommends: to Depends: fglrx-driver.
1338  * [amd64] Add ia32-libs to Build-Depends.
1339  * [amd64] Patch usr/X11R6/lib64/libGL.so.1.2 to fix the lib64 issue;
1340    Build-Depend on rpl for this purpose.
1341
1342  Changes by Eduard Bloch:
1343  * debian/README.Debian: removed the long collection of module-assistant
1344    calls with kernel-source specs again and again.
1345  * debian/control: moved kernel-package from Depends to Recommends in
1346    fglrx-kernel-src (it does not require it, even documented in
1347    README.Debian) and added module-assistant as alternative.
1348
1349 -- Flavio Stanchina <flavio@stanchina.net>  Thu,  2 Jun 2005 13:06:41 +0200
1350
1351fglrx-driver (8.12.10-1) experimental; urgency=low
1352
1353  * New upstream version. Thanks to Alexandru for the patch.
1354  * debian/rules: handle X.Org 6.8.2 (yes, I switched to Ubuntu's X.Org).
1355  * debian/patches-8.10.19/panel.diff: expand the "environment incomplete"
1356    error message in the panel's Makefile to show exactly what it was looking
1357    for, i.e. "$(MK_QTDIR)/include/qglobal.h"; hopefully, people seeing such
1358    message will understand that they need to install the Qt3 header files.
1359
1360 -- Flavio Stanchina <flavio@stanchina.net>  Sat,  9 Apr 2005 17:51:11 +0200
1361
1362fglrx-driver (8.10.19-2) experimental; urgency=low
1363
1364  * Ooops... "README.Debian" wasn't being put in the binary packages. Moved
1365    it into the debian directory so dh_installdocs finds it.
1366  * Add patches to support kernel 2.6.11:
1367    - 09-agp_backend
1368    - 10-remap_pfn_range
1369    - 11-four-level-pagetables
1370  * Add more patches in the limbo directory, and also put them in the kernel
1371    module's source tarball. Thanks to Alexandru for the patches.
1372  * Add Conflicts: nvidia-glx to fglrx-driver.
1373  * Change some Recommends: to Suggests:.
1374
1375 -- Flavio Stanchina <flavio@stanchina.net>  Sun, 27 Mar 2005 11:52:40 +0200
1376
1377fglrx-driver (8.10.19-1) experimental; urgency=low
1378
1379  * New upstream version.
1380  * Patches 07-include_pagemap, 08-firegl_pci_find_class included upstream.
1381
1382 -- Flavio Stanchina <flavio@stanchina.net>  Thu, 17 Feb 2005 11:12:57 +0100
1383
1384fglrx-driver (8.8.25-3) experimental; urgency=low
1385
1386  * Fix silly bug in preinst's diversion of 32-bit libGL.so on AMD64.
1387    [thanks to Nicolas Fournier]
1388
1389 -- Flavio Stanchina <flavio@stanchina.net>  Sat,  5 Feb 2005 16:13:51 +0100
1390
1391fglrx-driver (8.8.25-2) experimental; urgency=low
1392
1393  * AMD64 support! Thanks to Alexandru, Peter and others.
1394  * X.Org support! Thanks to Alexandru.
1395    - Note that I'm not building binary packages for AMD64 and X.Org, you'll
1396      need to build them yourself.
1397  * Removed changelog entries before 8.8.25 to unclutter the web page; they
1398    are still available as "changelog.old" for those interested.
1399
1400 -- Flavio Stanchina <flavio@stanchina.net>  Sat, 29 Jan 2005 15:31:17 +0100
1401
1402fglrx-driver (8.8.25-1) experimental; urgency=low
1403
1404  * New upstream version.
1405  * Trying to support module-assistant:
1406    - drop XFree86 version from package names
1407    - drop XFree86 and package versions from kernel source tarball's name
1408    - create link /usr/share/modass/packages/fglrx-kernel-src -> default.sh
1409  * Patch from Øystein GisnÃ¥s to make 'make-kpkg modules' work. It had been
1410    sitting in my inbox for a while now...
1411  * Support for previous driver versions has been removed to unclutter things
1412    a little bit.
1413
1414 -- Flavio Stanchina <flavio@stanchina.net>  Tue, 18 Jan 2005 21:58:49 +0100
1415
Note: See TracBrowser for help on using the repository browser.