source: pkg/main/libgnomeui/trunk/debian/patches/99_ltmain_as-needed.patch @ 3263

Revision 3263, 910 bytes checked in by alanbach-guest, 6 years ago (diff)
  • Sync'd with Debian 2.22.0.1-1
  • ltmain.sh

    old new  
    17931793        IFS="$save_ifs" 
    17941794        arg=`$echo "X$arg" | $Xsed -e "s/^ //"` 
    17951795        ;; 
     1796         
     1797       -Wl,--as-needed) 
     1798        deplibs="$deplibs $arg" 
     1799        continue 
     1800        ;; 
    17961801 
    17971802      -Wl,*) 
    17981803        args=`$echo "X$arg" | $Xsed -e "$sed_quote_subst" -e 's/^-Wl,//'` 
     
    21372142        lib= 
    21382143        found=no 
    21392144        case $deplib in 
     2145        -Wl,--as-needed) 
     2146          if test "$linkmode,$pass" = "prog,link"; then 
     2147            compile_deplibs="$deplib $compile_deplibs" 
     2148            finalize_deplibs="$deplib $finalize_deplibs" 
     2149          else 
     2150            deplibs="$deplib $deplibs" 
     2151          fi 
     2152          continue 
     2153          ;; 
    21402154        -mt|-mthreads|-kthread|-Kthread|-pthread|-pthreads|--thread-safe|-threads) 
    21412155          if test "$linkmode,$pass" = "prog,link"; then 
    21422156            compile_deplibs="$deplib $compile_deplibs" 
Note: See TracBrowser for help on using the repository browser.