source: pkg/main/control-center/trunk/debian/control.in @ 3320

Revision 3320, 4.8 KB checked in by alanbach-guest, 6 years ago (diff)
  • Added libslab-dev to build-deps
Line 
1Source: control-center
2Section: gnome
3Priority: optional
4Maintainer: Marco Cabizza <marco87@gmail.com>
5Uploaders: @GNOME_TEAM@
6Standards-Version: 3.7.3
7Build-Depends: cdbs (>= 0.4.41),
8               gnome-pkg-tools (>= 0.10),
9               dpkg-dev (>= 1.13.19),
10               debhelper (>= 5.0.0),
11               libgtk2.0-dev (>= 2.11.6),
12               libgnomeui-dev (>= 2.16.0-2),
13               intltool (>= 0.35.5),
14               libglade2-dev (>= 2.4.0-1),
15               libgnome-desktop-dev (>= 2.21.92-0ubuntu2),
16               zlib1g-dev,
17               flex,
18               libmetacity-dev (>= 1:2.21.21),
19               libxcursor-dev,
20               libbonobo2-dev (>= 2.6.2-6),
21               libeel2-dev (>= 2.21.5),
22               libnautilus-extension-dev (>= 2.21.6),
23               gnome-settings-daemon-dev,
24               libxrandr-dev,
25               docbook-to-man,
26               libgstreamer0.10-dev (>= 0.10.1.2),
27               libgstreamer-plugins-base0.10-dev (>= 0.10.1.2),
28               autotools-dev,
29               libasound2-dev (>= 1.0.3b-1) | not+linux-gnu,
30               libxss-dev,
31               libxinerama-dev,
32               libxft-dev (>= 2.1.2),
33               libxxf86misc-dev,
34               libxkbfile-dev,
35               libebook1.2-dev (>= 1.7.90),
36               desktop-file-utils,
37               gnome-doc-utils (>= 0.3.2),
38               libgnome-menu-dev (>= 2.12.0),
39               libx11-dev,
40               libxrender-dev,
41               libgconf2-dev,
42               libbonoboui2-dev,
43               libesd0-dev,
44               libgnomevfs2-dev,
45               libfontconfig1-dev,
46               libfreetype6-dev,
47               libglib2.0-dev (>> 2.13),
48               libxt-dev,
49               libhal-dev (>= 0.5.6),
50               libdbus-1-dev (>= 0.32),
51               libdbus-glib-1-dev (>= 0.32),
52               librsvg2-dev,
53               libpanel-applet2-dev,
54               libgnomekbd-dev (>= 2.21.4.1),
55               shared-mime-info,
56               libpango1.0-dev (>= 1.17),
57               libgnomekbdui-dev (>= 0.1),
58               scrollkeeper,
59               libxklavier12-dev,
60               libslab-dev
61
62Package: gnome-control-center
63Architecture: any
64Section: gnome
65Depends: ${shlibs:Depends},
66         ${misc:Depends},
67         capplets-data (>= ${gnome:Version}),
68         capplets-data (<< ${gnome:NextVersion}),
69         libgnome-window-settings1 (= ${binary:Version}),
70         gnome-settings-daemon,
71         gnome-menus (>= 2.12.0),
72         gnome-desktop-data,
73         gnome-icon-theme (>= 2.16),
74         desktop-file-utils,
75         libgnome-desktop-2 (>= 2.21.92-0ubuntu2)
76Recommends: bzip2,
77            evolution-data-server,
78            gnome-user-guide,
79            mousetweaks,
80            gnome-session
81Replaces: capplets
82Conflicts: capplets,
83           gnome-session (<< 2.21.90-0ubuntu1)
84Suggests: esound-clients,
85          gnome-screensaver | xscreensaver,
86          xbase-clients,
87          gstreamer0.10-alsa | gstreamer0.10-esd,
88          xrdb
89Description: utilities to configure the GNOME desktop
90 This package contains configuration applets for the GNOME desktop,
91 allowing to set accessibility configuration, desktop fonts, keyboard
92 and mouse properties, sound setup, desktop theme and background, user
93 interface properties, screen resolution, and other GNOME parameters.
94 .
95 It also contains a front end to these applets, which can also be
96 accessed with the GNOME panel or the Nautilus file manager.
97
98Package: capplets-data
99Architecture: all
100Section: gnome
101Depends: scrollkeeper, ${misc:Depends}
102Recommends: gnome-control-center (>= ${source:Version})
103Description: configuration applets for GNOME 2 - data files
104 This package contains data files (icons, pixmaps, locales files) needed by
105 the configuration applets in the gnome-control-center package.
106
107Package: libgnome-window-settings1
108Architecture: any
109Section: libs
110Depends: ${shlibs:Depends},
111         ${misc:Depends}
112Replaces: gnome-control-center (<< 1:2.14.1-1),
113          capplets
114Conflicts: capplets
115Description: Utility library for getting window manager settings
116 This package contains the libwindow-settings library, which is used by
117 the GNOME window managers.
118
119Package: libgnome-window-settings-dev
120Architecture: all
121Section: libdevel
122Depends: ${shlibs:Depends},
123         ${misc:Depends},
124         libgnome-window-settings1 (>= ${source:Version})
125Replaces: gnome-control-center (<< 1:2.14.1-1)
126Description: Utility library for getting window manager settings (headers)
127 This package contains the libwindow-settings library header files.
128
129Package: gnome-control-center-dev
130Architecture: all
131Section: devel
132Conflicts: libgnome-settings-daemon-dev
133Replaces: libgnome-settings-daemon-dev
134Depends: ${misc:Depends}
135Description: utilities to configure the GNOME desktop
136 This package contains the file required to get the keydirs location
Note: See TracBrowser for help on using the repository browser.